Bug 3094 - incorrect usage of '-' in manpages
Summary: incorrect usage of '-' in manpages
Status: RESOLVED FIXED
Alias: None
Product: systemtap
Classification: Unclassified
Component: documentation (show other bugs)
Version: unspecified
: P2 minor
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-19 18:17 UTC by Eugeniy Meshcheryakov
Modified: 2006-08-22 21:03 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
fix for the bug (3.34 KB, patch)
2006-08-19 18:18 UTC, Eugeniy Meshcheryakov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eugeniy Meshcheryakov 2006-08-19 18:17:51 UTC
Symbol '-' is sometimes incorrectly used in systemtap manpages to represent
minus sign. groff translates that symbol to hyphen (‐, U+2010) if UTF-8 locale
is used, that symbol may look identical to minus, but it will cause problems if
someone copies text from manpages to script or command-line. One should use '\-'
to represent minus sign in manpages.
Comment 1 Eugeniy Meshcheryakov 2006-08-19 18:18:25 UTC
Created attachment 1234 [details]
fix for the bug
Comment 2 Josh Stone 2006-08-22 21:03:31 UTC
Patch committed.

I was unable to reproduce the problem on my system, but I did find documentation
supporting what Eugeniy said.  From the groff_char manpage:

"the ISO Latin-1 ‘Hyphen, Minus Sign’ (code 45) prints as a hyphen; a minus sign
can be obtained with \-."