Bug 3032 - libelf Java interface leaks file descriptors
Summary: libelf Java interface leaks file descriptors
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Tim Moore
URL:
Keywords:
: 3014 (view as bug list)
Depends on:
Blocks: frysk-elfutils
  Show dependency treegraph
 
Reported: 2006-08-10 22:43 UTC by Tim Moore
Modified: 2006-11-22 00:24 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Moore 2006-08-10 22:43:43 UTC
The Elf wrapper for the external libelf library never closes the file descriptor
that is passed to libelf. With new behavior in frysk-core that causes the
executable of every running process to be examined, one of the tests quickly
blows up.
Comment 1 Yao Qi 2006-08-23 15:37:01 UTC
Close this bug
Comment 2 Andrew Cagney 2006-11-21 22:59:37 UTC
*** Bug 3014 has been marked as a duplicate of this bug. ***