Bug 30029 - Please patch email-to-bugzilla to recognize Bug: trailer
Summary: Please patch email-to-bugzilla to recognize Bug: trailer
Status: RESOLVED FIXED
Alias: None
Product: sourceware
Classification: Unclassified
Component: Infrastructure (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: overseers mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-01-20 16:29 UTC by Tom Tromey
Modified: 2023-02-08 03:26 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
the patch (657 bytes, patch)
2023-01-20 16:29 UTC, Tom Tromey
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Tromey 2023-01-20 16:29:15 UTC
Created attachment 14610 [details]
the patch

In gdb, we've starting using a Bug: git trailer to
link to a bug related to the patch.

The email-to-bugzilla script does not understand this
convention, so we also still write "PR mumble/NNNN".

Could you patch email-to-bugzilla to handle this?
I'm attaching a patch that I think should work.
Comment 1 Simon Marchi 2023-01-20 16:33:57 UTC
I have shown interest in doing that.  First converting the script to Python (because I don't know Perl, and I think that less and less people do), as well as adding simple regression tests, before adding more features.  Joel sent me current script, I will attach it.

I have started on December 3rd, according to the modification date, but haven't touched it since.  I will try to continue soon-ish, but if someone is motivated to do it right now, I can send what I have now.
Comment 2 Tom Tromey 2023-02-07 18:10:15 UTC
Worth noting that I supplied a patch, what I really am looking for here
is someone to install it.  It's great to rewrite this in Python but
there's no real need to wait on that for this feature.
Comment 3 Frank Ch. Eigler 2023-02-07 18:17:00 UTC
Sorry about the wait, committed.
Comment 4 Mark Wielaard 2023-02-07 19:15:45 UTC
(In reply to Simon Marchi from comment #1)
> I have shown interest in doing that.  First converting the script to Python
> (because I don't know Perl, and I think that less and less people do), as
> well as adding simple regression tests, before adding more features.  Joel
> sent me current script, I will attach it.
> 
> I have started on December 3rd, according to the modification date, but
> haven't touched it since.  I will try to continue soon-ish, but if someone
> is motivated to do it right now, I can send what I have now.

Might be nice to open a new bug and attach your work in progress so others can help out.
Comment 5 Tom Tromey 2023-02-08 02:13:15 UTC
(In reply to Frank Ch. Eigler from comment #3)
> Sorry about the wait, committed.

Thank you.