Bug 2973 - Multiple observers of the same type can be added to the timeline in the mainwindow
Summary: Multiple observers of the same type can be added to the timeline in the mainw...
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Phil Muldoon
URL:
Keywords:
: 3122 (view as bug list)
Depends on:
Blocks: 1632
  Show dependency treegraph
 
Reported: 2006-07-28 14:48 UTC by Mike Cvet
Modified: 2006-11-21 23:14 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Cvet 2006-07-28 14:48:15 UTC
Via the right-click menu in the mainwindow, observers of the same type may be
added multiple times.
Comment 1 Mike Cvet 2006-08-29 14:40:05 UTC
*** Bug 3122 has been marked as a duplicate of this bug. ***
Comment 2 Phil Muldoon 2006-08-29 14:49:07 UTC
2006-08-26  Phil Muldoon  <pmuldoon@redhat.com>
	
	* SessionProcDataModel.java (addTask): set parent GuiProc.
	* GuiTask.java (setParent): New.
	(getParent): New.
	* ObserversMenu.java (addGuiObject): Remove post
	observer check.
	(setCurrentProc): Disable observers in menu
	the the Proc already has.
	(setCurrentTask): Disable observers in menu
	the the Task *and* the Proc already has.
Comment 3 Phil Muldoon 2006-09-13 14:03:09 UTC
Due to the TaskObserverChanges in 

http://sourceware.org/bugzilla/show_bug.cgi?id=3190

This fix has regressed and has been reopened
Comment 4 Phil Muldoon 2006-09-13 15:49:12 UTC
Actual changes to debug process altered the references to the observers, and not
the changes in TasksObservers. Thus:

2006-09-13  Phil Muldoon  <pmuldoon@redhat.com>

	* ObserversMenu.java (setCurrentTask): Convert hash lookup key
	to observer.getName().
	(setCurrentProc): Ditto.
	(removeGuiObject): Ditto.
	(addGuiObject): Ditto.