Bug 2716 - Frysk debug session Druid - selecting parent/child process to monitor deletes process entry
Summary: Frysk debug session Druid - selecting parent/child process to monitor deletes...
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Phil Muldoon
URL:
Keywords:
Depends on:
Blocks: 3401
  Show dependency treegraph
 
Reported: 2006-05-31 15:04 UTC by Len DiMaggio
Modified: 2006-11-21 22:25 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Len DiMaggio 2006-05-31 15:04:25 UTC
Frysk debug session Druid - selecting parent/child process to monitor deletes
process entry - Frysk as built from CVS head - 20050529

In the debug session druid, selecting processes that are listed as either a
parent or child process deletes the process (and its parent or children) from
the process listing, but does not add the process to the $HOME/Frysk/Sessions file.

It is possible to select processes that are not listed as parents/children and
have them persisted in a Sessions file.
Comment 1 Phil Muldoon 2006-06-17 17:31:01 UTC
I've tried to reproduce this. If I select the Bash Process Group from the
available process group treeview, it gets populated into the selected process
group treeview. I can then add tagsets and/or observers and save it. I do find
the bash process group in the persisted session file.

Can you give some exact steps where I can replicate the behaviour you see?

Thanks!
Comment 2 Len DiMaggio 2006-06-19 13:38:08 UTC
This problem was reproducible on the day that I logged it - but not today (with
Frysk as built from CVS head on 20060616). Closing as non-reproducible. Whatever
the problem was, it got fixed.