Bug 2694 - gcc-3.4.3 glibc2.3.3 kernel 2.4.31 for sh4-linux build fails
Summary: gcc-3.4.3 glibc2.3.3 kernel 2.4.31 for sh4-linux build fails
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: nptl (show other bugs)
Version: 2.3.3
: P2 critical
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-24 08:26 UTC by Vijay Rathi
Modified: 2006-05-24 14:52 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vijay Rathi 2006-05-24 08:26:25 UTC
I am trying to build the toolchain with set gcc-3.4.3, glibc2.3.3 and kernel
header 2.4.31 for sh4 platform.
While building glibc i am facing following problem,

make -s -C nptl subdir_lib
make[2]: Entering directory
`/home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3/nptl'
mkdir /home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3/build-sh4-linux-nptl/nptl
make[2]: Leaving directory `/home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3/nptl'
make[2]: Entering directory
`/home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3/nptl'
../nptl/sysdeps/unix/sysv/linux/register-atfork.c: In function `__register_atfork':
../nptl/sysdeps/unix/sysv/linux/register-atfork.c:88: warning: unused variable `val'
../nptl/sysdeps/unix/sysv/linux/register-atfork.c: In function `free_mem':
../nptl/sysdeps/unix/sysv/linux/register-atfork.c:115: warning: unused variable
`val'
../nptl/sysdeps/unix/sysv/linux/unregister-atfork.c: In function
`__unregister_atfork':
../nptl/sysdeps/unix/sysv/linux/unregister-atfork.c:57: warning: unused variable
`val'
../nptl/sysdeps/unix/sysv/linux/register-atfork.c: In function `__register_atfork':
../nptl/sysdeps/unix/sysv/linux/register-atfork.c:88: warning: unused variable `val'
../nptl/sysdeps/unix/sysv/linux/register-atfork.c: In function `free_mem':
../nptl/sysdeps/unix/sysv/linux/register-atfork.c:115: warning: unused variable
`val'
../nptl/sysdeps/unix/sysv/linux/unregister-atfork.c: In function
`__unregister_atfork':
../nptl/sysdeps/unix/sysv/linux/unregister-atfork.c:57: warning: unused variable
`val'
init.c:53:3: #error "define __NR_set_tid_address"
init.c: In function `__pthread_initialize_minimal_internal':
init.c:216: error: `__NR_set_tid_address' undeclared (first use in this function)
init.c:216: error: (Each undeclared identifier is reported only once
init.c:216: error: for each function it appears in.)
make[2]: ***
[/home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3/build-sh4-linux-nptl/nptl/init.o]
Error 1
make[2]: Leaving directory `/home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3/nptl'
make[1]: *** [nptl/subdir_lib] Error 2
make[1]: Leaving directory `/home/vijayr/WORKSHORE/rpm_build/BUILD/glibc-2.3.3'
make: *** [all] Error 2
Comment 1 Ulrich Drepper 2006-05-24 14:52:18 UTC

*** This bug has been marked as a duplicate of 333 ***