Bug 2689 - Frysk GUI crashes constantly
Summary: Frysk GUI crashes constantly
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P1 normal
Target Milestone: ---
Assignee: Sami Wagiaalla
URL:
Keywords:
Depends on:
Blocks: 1632
  Show dependency treegraph
 
Reported: 2006-05-23 19:11 UTC by Len DiMaggio
Modified: 2006-11-21 22:22 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Len DiMaggio 2006-05-23 19:11:08 UTC
The Frysk GUI as built from CVS head (May 20, 21) has a tendency to hit a null
pointer exception frequently - well, actually constantly. It looks like Frysk
can't handle new processes being created or existing processes exiting.
Comment 1 Len DiMaggio 2006-05-23 19:15:23 UTC
java.lang.NullPointerException
   at frysk.gui.monitor.GuiProc.getExecutableName (FryskGui)
   at frysk.gui.monitor.ProcWiseDataModel$ProcDestroyedObserver$3.run (FryskGui)
   at org.gnu.glib.CustomEvents.runEvents (libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main (libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main (libgtkjava-2.8.so)
   at frysk.gui.Gui.gui (FryskGui)
   at frysk.gui.FryskGui.main (FryskGui)
Comment 2 Sami Wagiaalla 2006-05-25 14:11:27 UTC
Fix commited.
Give it a run :)
Comment 3 Sami Wagiaalla 2006-05-26 12:28:23 UTC
fix confermed