Bug 26444 - UBSAN error: bfd/elf32-crx.c:512:51:
Summary: UBSAN error: bfd/elf32-crx.c:512:51:
Status: RESOLVED DUPLICATE of bug 26442
Alias: None
Product: binutils
Classification: Unclassified
Component: binutils (show other bugs)
Version: 2.34
: P2 normal
Target Milestone: ---
Assignee: Alan Modra
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-20 12:21 UTC by Martin Liska
Modified: 2020-08-30 23:01 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed: 2020-08-30 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liska 2020-08-20 12:21:46 UTC
The following fails when I build binutils with:
configure --build=x86_64-linux --disable-nls --disable-gdb --disable-gdbserver --disable-sim --disable-readline --disable-libdecnumber --enable-obsolete --target=crx-elf CFLAGS="-g -O2 -fsanitize=address,undefined -Wno-error" CXXLAGS="-g -O2 -fsanitize=address,undefined -Wno-error" LDFLAGS="-ldl"
Target: crx-elf
| 	exit( YY_EXIT_FAILURE );
Executing on host: sh -c {./ld-new   -L/home/mliska/Programming/binutils/ld/testsuite/ld-crx  -T /home/mliska/Programming/binutils/ld/testsuite/ld-crx/crx.ld -o tmpdir/dump tmpdir/reloc-abs32.o  2>&1}  /dev/null dump.tmp (timeout = 300)
/home/mliska/Programming/binutils/bfd/elf32-crx.c:512:51: runtime error: left shift of 2147483647 by 1 places cannot be represented in type 'int'
Comment 1 Alan Modra 2020-08-30 23:01:50 UTC
Dup

*** This bug has been marked as a duplicate of bug 26442 ***