Bug 26149 - PKU is usable only if OSPKE is set
Summary: PKU is usable only if OSPKE is set
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.32
: P2 normal
Target Milestone: 2.32
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-22 12:55 UTC by H.J. Lu
Modified: 2020-07-07 08:17 UTC (History)
1 user (show)

See Also:
Host:
Target: i386,x86-64
Build:
Last reconfirmed:
fweimer: security-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2020-06-22 12:55:45 UTC
bit_OSPKE indicates that OS supports PKU.
Comment 1 H.J. Lu 2020-06-22 20:28:25 UTC
Fixed by

commit ecbbadbf107ea1155ae5b71a8b7bd48f38c76731
Author: H.J. Lu <hjl.tools@gmail.com>
Date:   Wed Jun 17 06:34:46 2020 -0700

    x86: Update CPU feature detection [BZ #26149]