Bug 2529 - tst-timer check fails: segmentation fault
Summary: tst-timer check fails: segmentation fault
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.4
: P2 normal
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-08 20:06 UTC by tensor5
Modified: 2006-04-09 04:44 UTC (History)
1 user (show)

See Also:
Host: x86_64-pc-linux-gnu
Target: x86_64-pc-linux-gnu
Build: x86_64-pc-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tensor5 2006-04-08 20:06:30 UTC
The following error appear when I test the newly built glibc-2.4. My system is
an athlon64, and I'm using gcc-4.0.2 and glibc-2.3.6
I tried different version of the kernel: 2.6.16-mm2, 2.6.17-rc1-mm2, and the
respective headers. I also tried differnt cflags. The build runs fine.

make check
[...]
x86_64-pc-linux-gnu-gcc ../nptl/sysdeps/pthread/tst-timer.c -c -std=gnu99 -O3
-Wall -Winline -Wwrite-strings -fmerge-all-constants -march=athlon64
-Wstrict-prototypes  -fomit-frame-pointer    -I../include
-I/home/nicola/rpm/BUILD/glibc-2.4-build/rt
-I/home/nicola/rpm/BUILD/glibc-2.4-build -I../sysdeps/x86_64/elf
-I../nptl/sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/x86_64
-I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux
-I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux
-I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman
-I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv
-I../sysdeps/unix/x86_64 -I../nptl/sysdeps/unix -I../sysdeps/unix
-I../sysdeps/posix -I../sysdeps/x86_64/fpu -I../nptl/sysdeps/x86_64
-I../sysdeps/x86_64 -I../sysdeps/wordsize-64 -I../sysdeps/ieee754/ldbl-96
-I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754
-I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl  -I.. -I../libio -I. 
-D_LIBC_REENTRANT -include ../include/libc-symbols.h   -DNOT_IN_libc=1    -o
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.o -MD -MP -MF
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.o.dt -MT
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.o
x86_64-pc-linux-gnu-gcc -nostdlib -nostartfiles -o
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer 
-Wl,-dynamic-linker=/lib/ld-linux-x86-64.so.2   -Wl,-z,combreloc -Wl,-z,relro
/home/nicola/rpm/BUILD/glibc-2.4-build/csu/crt1.o
/home/nicola/rpm/BUILD/glibc-2.4-build/csu/crti.o `x86_64-pc-linux-gnu-gcc
--print-file-name=crtbegin.o`
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.o
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/librt.so
/home/nicola/rpm/BUILD/glibc-2.4-build/nptl/libpthread_nonshared.a
/home/nicola/rpm/BUILD/glibc-2.4-build/nptl/libpthread.so 
-Wl,-rpath-link=/home/nicola/rpm/BUILD/glibc-2.4-build:/home/nicola/rpm/BUILD/glibc-2.4-build/math:/home/nicola/rpm/BUILD/glibc-2.4-build/elf:/home/nicola/rpm/BUILD/glibc-2.4-build/dlfcn:/home/nicola/rpm/BUILD/glibc-2.4-build/nss:/home/nicola/rpm/BUILD/glibc-2.4-build/nis:/home/nicola/rpm/BUILD/glibc-2.4-build/rt:/home/nicola/rpm/BUILD/glibc-2.4-build/resolv:/home/nicola/rpm/BUILD/glibc-2.4-build/crypt:/home/nicola/rpm/BUILD/glibc-2.4-build/nptl
/home/nicola/rpm/BUILD/glibc-2.4-build/libc.so.6
/home/nicola/rpm/BUILD/glibc-2.4-build/libc_nonshared.a -lgcc -Wl,--as-needed
-lgcc_s  -Wl,--no-as-needed `x86_64-pc-linux-gnu-gcc --print-file-name=crtend.o`
/home/nicola/rpm/BUILD/glibc-2.4-build/csu/crtn.o
GCONV_PATH=/home/nicola/rpm/BUILD/glibc-2.4-build/iconvdata LC_ALL=C  
/home/nicola/rpm/BUILD/glibc-2.4-build/elf/ld-linux-x86-64.so.2 --library-path
/home/nicola/rpm/BUILD/glibc-2.4-build:/home/nicola/rpm/BUILD/glibc-2.4-build/math:/home/nicola/rpm/BUILD/glibc-2.4-build/elf:/home/nicola/rpm/BUILD/glibc-2.4-build/dlfcn:/home/nicola/rpm/BUILD/glibc-2.4-build/nss:/home/nicola/rpm/BUILD/glibc-2.4-build/nis:/home/nicola/rpm/BUILD/glibc-2.4-build/rt:/home/nicola/rpm/BUILD/glibc-2.4-build/resolv:/home/nicola/rpm/BUILD/glibc-2.4-build/crypt:/home/nicola/rpm/BUILD/glibc-2.4-build/nptl
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer  >
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.out
/bin/sh: line 1: 25605 Segmentation fault     
GCONV_PATH=/home/nicola/rpm/BUILD/glibc-2.4-build/iconvdata LC_ALL=C
/home/nicola/rpm/BUILD/glibc-2.4-build/elf/ld-linux-x86-64.so.2 --library-path
/home/nicola/rpm/BUILD/glibc-2.4-build:/home/nicola/rpm/BUILD/glibc-2.4-build/math:/home/nicola/rpm/BUILD/glibc-2.4-build/elf:/home/nicola/rpm/BUILD/glibc-2.4-build/dlfcn:/home/nicola/rpm/BUILD/glibc-2.4-build/nss:/home/nicola/rpm/BUILD/glibc-2.4-build/nis:/home/nicola/rpm/BUILD/glibc-2.4-build/rt:/home/nicola/rpm/BUILD/glibc-2.4-build/resolv:/home/nicola/rpm/BUILD/glibc-2.4-build/crypt:/home/nicola/rpm/BUILD/glibc-2.4-build/nptl
/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer
>/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.out
make[2]: *** [/home/nicola/rpm/BUILD/glibc-2.4-build/rt/tst-timer.out] Error 139
make[2]: Leaving directory `/tmp/glibc-2.4/rt'
make[1]: *** [rt/tests] Error 2
make[1]: Leaving directory `/tmp/glibc-2.4'
make: *** [check] Error 2
Comment 1 Ulrich Drepper 2006-04-09 04:44:32 UTC

*** This bug has been marked as a duplicate of 333 ***