Bug 25186 - Vim ftplugin creates conflicting autocmd group
Summary: Vim ftplugin creates conflicting autocmd group
Status: RESOLVED FIXED
Alias: None
Product: systemtap
Classification: Unclassified
Component: documentation (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-11 08:05 UTC by Jonathan
Modified: 2019-11-25 02:34 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan 2019-11-11 08:05:49 UTC
There's a long standing bug in the provided Vim plugin which breaks the expected case insensitive behaviour of Vim's autocmd event's.

There is a Stack Exchange description of the problem here:
https://vi.stackexchange.com/questions/5546/why-doesnt-vim-work-with-lowercase-event-names/5731#5731

By using the autocmd group name "filetype", which has the same name as an autocmd "event", subsequent use of case insensitive events will try to allocate the command to the group created in the systemtap Vim plugin.

I discovered this when installing the "Development Libraries" group on Fedora 31 which includes the systemtap-devel package. After this, other unrelated Vim plugins broke.
Comment 1 Frank Ch. Eigler 2019-11-24 22:38:26 UTC
I was not able to reproduce the failure here, but speculatively committed
a fix by renaming the augroup.
Comment 2 Jonathan 2019-11-25 02:34:35 UTC
Thanks Frank!