Bug 24831 - FAIL: gdb.multi/tids.exp: two inferiors: info threads -1
Summary: FAIL: gdb.multi/tids.exp: two inferiors: info threads -1
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: testsuite (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-22 08:28 UTC by Tom de Vries
Modified: 2019-07-24 06:37 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Tentative patch (656 bytes, patch)
2019-07-22 08:57 UTC, Tom de Vries
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom de Vries 2019-07-22 08:28:18 UTC
I observe these fails:
...
FAIL: gdb.multi/tids.exp: two inferiors: info threads -1
FAIL: gdb.multi/tids.exp: two inferiors: info threads -$one
...

In more detail:
...
(gdb) PASS: gdb.multi/tids.exp: two inferiors: thread apply 2-$one
info threads -1^M
Unrecognized option at: -1^M
(gdb) FAIL: gdb.multi/tids.exp: two inferiors: info threads -1
thread apply -1^M
Invalid thread ID: -1^M
(gdb) PASS: gdb.multi/tids.exp: two inferiors: thread apply -1
info threads -$one^M
Unrecognized option at: -$one^M
(gdb) FAIL: gdb.multi/tids.exp: two inferiors: info threads -$one
...

Also observed here: https://sourceware.org/ml/gdb-testers/2019-q3/msg00316.html .

Fallout from 54d6600669 'Make "info threads" use the gdb::option framework'
Comment 1 Tom de Vries 2019-07-22 08:57:12 UTC
Created attachment 11916 [details]
Tentative patch
Comment 2 Tom de Vries 2019-07-22 08:57:55 UTC
(In reply to Tom de Vries from comment #1)
> Created attachment 11916 [details]
> Tentative patch

Pedro, WDYT?
Comment 3 cvs-commit@gcc.gnu.org 2019-07-24 06:36:57 UTC
The master branch has been updated by Tom de Vries <vries@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=024a5840006aba9ba698aa9d868a7394016dd4a0

commit 024a5840006aba9ba698aa9d868a7394016dd4a0
Author: Tom de Vries <tdevries@suse.de>
Date:   Wed Jul 24 08:36:17 2019 +0200

    Update expected info threads error messages in gdb.multi/tids.exp
    
    We currently have these FAILs:
    ...
    FAIL: gdb.multi/tids.exp: two inferiors: info threads -1
    FAIL: gdb.multi/tids.exp: two inferiors: info threads -$one
    ...
    because we're expecting:
    ...
    Invalid thread ID: -1
    ...
    but instead we have:
    ...
    Unrecognized option at: -1
    ...
    
    This error message for info threads has changed since commit 54d6600669
    'Make "info threads" use the gdb::option framework'.
    
    Update the test accordingly.
    
    Tested on x86_64-linux.
    
    gdb/testsuite/ChangeLog:
    
    2019-07-24  Tom de Vries  <tdevries@suse.de>
    
    	PR testsuite/24831
    	* gdb.multi/tids.exp: Update error messages for info threads.
Comment 4 Tom de Vries 2019-07-24 06:37:34 UTC
Patch committed, marking resolved-fixed.