Bug 24656 - Target variables for tracepoints differ between traditional sytemtap backend and bpf backend
Summary: Target variables for tracepoints differ between traditional sytemtap backend ...
Status: RESOLVED DUPLICATE of bug 23866
Alias: None
Product: systemtap
Classification: Unclassified
Component: bpf (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-10 14:35 UTC by William Cohen
Modified: 2019-06-10 14:53 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Cohen 2019-06-10 14:35:45 UTC
After getting the target() function working I expected that the cycle_thief.stp example would work with the bpf backend.  However, found that the bpf backend has a different set of target variables available than the original systemtap kernel module backend:

[wcohen@localhost systemtap]$ ../install/bin/stap -L 'kernel.trace("sched_switch")'
kernel.trace("sched:sched_switch") $preempt:bool $prev:struct task_struct* $next:struct task_struct*
[wcohen@localhost systemtap]$ ../install/bin/stap --bpf -L 'kernel.trace("sched_switch")'
kernel.trace("sched:sched_switch") $prev_comm:char[] $prev_pid:pid_t $prev_prio:int $prev_state:long int $next_comm:char[] $next_pid:pid_t $next_prio:int

Did not see this type of difference between probes for a kernel function. For example the vfs_read probes are the same:

[wcohen@localhost systemtap]$ ../install/bin/stap -L 'kernel.function("vfs_read")' 
kernel.function("vfs_read@fs/read_write.c:446") $file:struct file* $buf:char* $count:size_t $pos:loff_t*
[wcohen@localhost systemtap]$ ../install/bin/stap --bpf -L 'kernel.function("vfs_read")' 
kernel.function("vfs_read@fs/read_write.c:446") $file:struct file* $buf:char* $count:size_t $pos:loff_t*
Comment 1 Frank Ch. Eigler 2019-06-10 14:53:41 UTC
dupe

*** This bug has been marked as a duplicate of bug 23866 ***