Bug 2441 - Source window gets NPE's when expanding/contracting inline code
Summary: Source window gets NPE's when expanding/contracting inline code
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Adam Jocksch
URL:
Keywords:
Depends on:
Blocks: 1633
  Show dependency treegraph
 
Reported: 2006-03-09 16:28 UTC by Rick Moseley
Modified: 2006-11-21 18:00 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Moseley 2006-03-09 16:28:25 UTC
When I bring up a source window and bring up the test source with the inline
code that can be expanded and go through and expand all of the inline code and
then contract it.  It usually does not take very long for the following
stacktrace to occur:

java.lang.NullPointerException
   at frysk.gui.srcwin.InlineBuffer.getVariable (FryskGui)
   at frysk.gui.srcwin.SourceView.mousedOverText (FryskGui)
   at frysk.gui.srcwin.SourceView$SourceViewListener.mouseMotionEvent (FryskGui)
   at org.gnu.gtk.Widget.fireMouseMotionEvent (libgtkjava-2.8.so)
   at org.gnu.gtk.Widget.handleMouseMotion (libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main (libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main (libgtkjava-2.8.so)
   at frysk.gui.Gui.gui (FryskGui)
   at frysk.gui.FryskGui.main (FryskGui)
Comment 1 Adam Jocksch 2006-03-09 16:44:33 UTC
This was caused by not checking to see if the return value from a function was
null or not. This has been corrected

2006-03-09  Adam Jocksch  <ajocksch@redhat.com>

	* InlineBuffer.java (getVariable): Now adds check for the DOMLine
	being null since this occurs in corner cases.