Bug 2410 - glibc compilation fails: "subtraction of two symbols in different sections"
Summary: glibc compilation fails: "subtraction of two symbols in different sections"
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.6
: P2 critical
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-02 18:21 UTC by Perttu Halonen
Modified: 2006-03-02 19:53 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Perttu Halonen 2006-03-02 18:21:28 UTC
Compiling glibc 2.3.6 obtained today from ftp.funet.fi/pub/gnu/prep/glibc
crashes here:

gcc ../sysdeps/i386/i686/memcmp.S -c  -I../include -I. -I/home/perttu/src/uutta/
glibc-rakennus/string -I.. -I../libio  -I/home/perttu/src/uutta/glibc-rakennus -
I../sysdeps/i386/elf -I../linuxthreads/sysdeps/unix/sysv/linux/i386 -I../linuxth
reads/sysdeps/unix/sysv/linux -I../linuxthreads/sysdeps/pthread -I../sysdeps/pth
read -I../linuxthreads/sysdeps/unix/sysv -I../linuxthreads/sysdeps/unix -I../lin
uxthreads/sysdeps/i386/i686 -I../linuxthreads/sysdeps/i386 -I../libidn/sysdeps/u
nix -I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux -I../sysdeps/
gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../
sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdep
s/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../sysdeps/i386/i686 -I..
/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../sysdeps/i386 -I../sysdeps/wordsize
-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee75
4/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -nos
tdinc -isystem /usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/include -isystem /usr/sr
c/linux-2.6.11.10/include/ -D_LIBC_REENTRANT -include ../include/libc-symbols.h 
      -DASSEMBLER  -DGAS_SYNTAX    -o /home/perttu/src/uutta/glibc-rakennus/stri
ng/memcmp.o -MD -MP -MF /home/perttu/src/uutta/glibc-rakennus/string/memcmp.o.dt
 -MT /home/perttu/src/uutta/glibc-rakennus/string/memcmp.o
/tmp/ccMyRCvc.s: Assembler messages:
/tmp/ccMyRCvc.s:414: Error: subtraction of two symbols in different sections `.r
odata' {.rodata section} - `memcmp' {.text section} at file address 68
make[2]: *** [/home/perttu/src/uutta/glibc-rakennus/string/memcmp.o] Error 1
make[2]: Leaving directory `/home/perttu/src/uutta/glibc-2.3.6/string'
make[1]: *** [string/subdir_lib] Error 2
make[1]: Leaving directory `/home/perttu/src/uutta/glibc-2.3.6'
make: *** [all] Error 2

Build environment is as described in INSTALL file. The configure command line was:

../glibc-2.3.6/configure --prefix=/usr --enable-add-ons=linuxthreads,libidn 
--with-headers=/usr/src/linux-2.6.11.10/include/ --enable-kernel=2.4.20 --disabl
e-profile

The glibc version currently in use is 2.3.1. The compilation was done using gcc
3.2.1.
Comment 1 Perttu Halonen 2006-03-02 19:53:14 UTC
Hmm, should have read the most commonly reported bugs first.

*** This bug has been marked as a duplicate of 333 ***