Bug 2291 - building of Frysk source rpm failed due to missing XFree86-devel/xorg-x11-devel
Summary: building of Frysk source rpm failed due to missing XFree86-devel/xorg-x11-devel
Status: RESOLVED INVALID
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Andrew Cagney
URL:
Keywords:
Depends on:
Blocks: 2104 2297
  Show dependency treegraph
 
Reported: 2006-02-07 08:24 UTC by Wu Zhou
Modified: 2006-02-08 04:26 UTC (History)
0 users

See Also:
Host: powerpc-redhat-linux-gnu
Target: powerpc64-redhat-linux-gnu
Build: powerpc-redhat-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wu Zhou 2006-02-07 08:24:42 UTC
I am trying to build the latest (0128 version) Frysk source rpm on FC5-test2 /
PPC64 (I believe this is common to all platform under FC5-test2).  Here is the
failure message:

[root@plinuxt2 redhat]# rpmbuild -ba ./SPECS/frysk.spec
error: Failed build dependencies:
        XFree86-devel is needed by frysk-0.0.1.2006.01.28-0.EL4.1.ppc64
        xorg-x11-devel is needed by frysk-0.0.1.2006.01.28-0.EL4.1.ppc64
        xorg-x11-devel >= 4.2.99 is needed by frysk-0.0.1.2006.01.28-0.EL4.1.ppc64

I take a look at the FC5 rpm tree on the fedora home page ( at
http://download.fedora.redhat.com/pub/fedora/linux/core/development/[ppc64|ppc|i386]/Fedora/RPMS/)

There is no xorg-x11-devel/XFree86 at all.  I had also a check with FC4.  It has
xorg-x11-devel package.

Anyone ever successfully build Frysk from the source rpm package on FC5?  If you
do, did you made any trick or magic?  If so, please tell me.  Thanks.
Comment 1 Andrew Cagney 2006-02-07 17:07:51 UTC
Just a sanity check, that the RHEL-4 or FC-5 RPM?  The latter can be found on
the official fedora site in the devel tree.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/frysk-0.0.1.2006.01.22-0.FC5.1.src.rpm
Comment 2 Wu Zhou 2006-02-08 04:26:31 UTC
Sorry.  I take if for granted that FC5 are using the same source rpm as RHEL4. 
Close this.