Bug 2288 - frysk dies after a few seconds
Summary: frysk dies after a few seconds
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P1 normal
Target Milestone: ---
Assignee: Andrew Cagney
Depends on: 2325 2299 2324
Blocks: 3398 2104
  Show dependency treegraph
Reported: 2006-02-06 20:58 UTC by Andrew Cagney
Modified: 2006-10-19 18:53 UTC (History)
0 users

See Also:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Cagney 2006-02-06 20:58:43 UTC
From: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179811

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20060202
Fedora/ Firefox/

Description of problem:
I fire up frysk.  Try and play with it and it disappears.  If I run it from a
terminal it spits out this:

[decker@cheetah ~]$ frysk
Found subnode: /theManager
Found subnode: /theManager/logWindow
Found subnode: /theManager/mainWindow
Key: size.width Value: 640
Key: size.height Value: 480
Key: position.y Value: 0
Key: position.x Value: 0
Found subnode: /theManager/mainWindow/allProcWidget
Key: vPane.position Value: 365
Found subnode: /theManager/programAddWindow
Key: size.width Value: 500
Key: size.height Value: 480
Key: position.y Value: 0
Key: position.x Value: 0
Exception in thread "main" java.lang.NullPointerException
*** Got java.lang.NullPointerException while trying to print stack trace.
[decker@cheetah ~]$

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Fire up frysk
2. Play with it for a few seconds.
Comment 1 Phil Muldoon 2006-02-21 21:33:10 UTC
Is this fixed in the latest resping of Frysk (for RHEL4-U3?). 
Comment 2 Andrew Cagney 2006-02-22 17:25:36 UTC
This is against FC-5.  I've pushed through
frysk- which contains a number of crashing fixes.

Note though that http://sourceware.org/bugzilla/show_bug.cgi?id=2325 is still open.
Comment 3 Andrew Cagney 2006-05-12 17:32:39 UTC
FYI, the following instability problems have been fixed:
- backtraces causing aborts or panics
- hang due to G.C. problems (worked around)
- java-gnome memory corruptions
- weak reference bugs (compiler upgraded)
I'll assume this very generic problem is fixed in top-of-tree builds.  If
problems continue using frysk's top-of-tree and latest GCJ please open or
re-open the bug.