Bug 2219 - A patch to build frysk on PPC64 in 64-bits mode
Summary: A patch to build frysk on PPC64 in 64-bits mode
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Andrew Cagney
URL:
Keywords:
Depends on: 2202
Blocks: 2188
  Show dependency treegraph
 
Reported: 2006-01-27 07:18 UTC by Wu Zhou
Modified: 2006-05-05 17:56 UTC (History)
1 user (show)

See Also:
Host: powerpc-redhat-linux-gnu
Target: powerpc64-redhat-linux-gnu
Build: powerpc-redhat-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wu Zhou 2006-01-27 07:18:55 UTC
I managed to build the latest frysk rpm in 64-bits mode on PPC64, here is the
patch to frysk.spec:


175c175
< ExclusiveArch: %{ix86}
---
> # ExclusiveArch: %{ix86}
350c350
< 	local c=" -mminimal-toc"
---
> 	local c=" -mminimal-toc -m64 "
355a356,359
> 	echo export \'FREETYPE_LIBS="-L/usr/%{_lib} -lfreetype"\'
> 	echo export \'LIBJPEG="-L/usr/%{_lib} -ljpeg"\'
> 	echo export \'EXPAT_LIBS="-L/usr/%{_lib} -lexpat"\'
> 	echo export \'X_LIBS="-L/usr/X11R6/%{_lib} -lX11"\'
644c648
< %define pango_makeflags "%{glib_cflags}" "%{cairo_cflags}" "FONTCONFIG_LIBS =
%{lib_fontconfig}" "GLIB_LIBS = %{lib_gobject} %{lib_gmodule} %{lib_gthread}
%{lib_glib}" "CAIRO_LIBS = %{lib_cairo}" "XFT_CFLAGS =
-I$RPM_BUILD_ROOT/%{__frysk_includedir} -I/usr/X11R6/include
-I/usr/include/freetype2 -I/usr/include/freetype2/config" "XFT_LIBS =
-L/usr/X11R6/%{_lib} -lXft -lX11 -lfreetype -lXrender %{lib_fontconfig}"
---
> %define pango_makeflags "%{glib_cflags}" "%{cairo_cflags}" "FONTCONFIG_LIBS =
%{lib_fontconfig}" "GLIB_LIBS = %{lib_gobject} %{lib_gmodule} %{lib_gthread}
%{lib_glib}" "CAIRO_LIBS = %{lib_cairo}" "XFT_CFLAGS =
-I$RPM_BUILD_ROOT/%{__frysk_includedir} -I/usr/X11R6/include
-I/usr/include/freetype2 -I/usr/include/freetype2/config" "XFT_LIBS =
-L/usr/X11R6/%{_lib} -L/usr/%{_lib} -lXft -lX11 -lfreetype -lXrender
%{lib_fontconfig}"
724c728
< %define libglade2_makeflags "LIBGLADE_CFLAGS = %{GLIB_CFLAGS} %{GTK_CFLAGS}
%{CAIRO_CFLAGS} %{PANGO_CFLAGS} -I/usr/include/libxml2 %{ATK_CFLAGS}"
"LIBGLADE_LIBS = -Wl,--export-dynamic -lxml2 -lpthread -lz %{lib_gtk_x11}
%{lib_gdk_x11} %{lib_gdk_pixbuf} %{lib_atk} -lm %{lib_pangocairo}
%{lib_pangoft2} %{lib_pango} %{lib_cairo} %{lib_gobject} %{lib_gmodule}
%{lib_gthread} %{lib_glib} -ldl"
---
> %define libglade2_makeflags "LIBGLADE_CFLAGS = %{GLIB_CFLAGS} %{GTK_CFLAGS}
%{CAIRO_CFLAGS} %{PANGO_CFLAGS} -I/usr/include/libxml2 %{ATK_CFLAGS}"
"LIBGLADE_LIBS = -Wl,--export-dynamic -L/usr/lib64 -lxml2 -lpthread -lz
%{lib_gtk_x11} %{lib_gdk_x11} %{lib_gdk_pixbuf} %{lib_atk} -lm %{lib_pangocairo}
%{lib_pangoft2} %{lib_pango} %{lib_cairo} %{lib_gobject} %{lib_gmodule}
%{lib_gthread} %{lib_glib} -ldl"
762c766
< %define libvte_java_makeflags %{libglade_java_makeflags} "GNOME_CFLAGS =
-pthread -DORBIT2=1 -I$RPM_BUILD_ROOT/%{__frysk_includedir}/gtk-2.0
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/glib-2.0
-I$RPM_BUILD_ROOT/%{__frysk_libdir}/glib-2.0/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/pango-1.0 -I/usr/include/
-I/usr/include/freetype2 -I$RPM_BUILD_ROOT/%{__frysk_libdir}/gtk-2.0/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/atk-1.0
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/cairo -I/usr/include/libgnomeui-2.0
-I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0
-I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2" "GNOME_LIBS =
-Wl,--export-dynamic -pthread -L/usr/X11R6/%{_lib} -lgnomeui-2 -lSM -lICE
-lbonoboui-2 -lxml2 -lpthread -lz -lgnome-2 -lpopt -lbonobo-2 -lgconf-2
-lgnomevfs-2 -lbonobo-activation -lORBit-2 %{lib_gthread} -lgnomecanvas-2
-lart_lgpl_2 %{lib_pangoft2} %{lib_gtk_x11} %{lib_gdk_x11} %{lib_atk}
-lgdk_pixbuf-2.0 -lm %{lib_pangocairo} %{lib_pango} %{lib_cairo} %{lib_gobject}
%{lib_gmodule} -ldl %{lib_glib}" "VTE_CFLAGS =
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/glib-2.0
-I$RPM_BUILD_ROOT/%{__frysk_libdir}/glib-2.0/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/gtk-2.0 -I/usr/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/pango-1.0 -I/usr/X11R6/include
-I/usr/include/freetype2 -I/usr/include/freetype2/config
-I$RPM_BUILD_ROOT/%{__frysk_libdir}/gtk-2.0/include
-I$RPM_BUILD_DIR/%{__frysk_includedir}/atk-1.0
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/cairo" "VTE_LIBS = -L/usr/X11R6/%{_lib}
-lvte -lz -lncurses -lSM -lICE -lXft -lX11 -lfreetype -lXrender %{lib_gtk_x11}
%{lib_pangoxft} %{lib_pangox} %{lib_fontconfig} %{lib_gdk_x11} %{lib_atk}
%{lib_gdk_pixbuf} -lm %{lib_pangocairo} %{lib_cairo} %{lib_pangoft2}
%{lib_pango} %{lib_gobject} %{lib_gmodule} -ldl %{lib_glib}" "JGJAVA_CFLAGS =
%{JGJAVA_CFLAGS} -I $RPM_BUILD_ROOT/%{__frysk_includedir}"
---
> %define libvte_java_makeflags %{libglade_java_makeflags} "GNOME_CFLAGS =
-pthread -DORBIT2=1 -I$RPM_BUILD_ROOT/%{__frysk_includedir}/gtk-2.0
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/glib-2.0
-I$RPM_BUILD_ROOT/%{__frysk_libdir}/glib-2.0/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/pango-1.0 -I/usr/include/
-I/usr/include/freetype2 -I$RPM_BUILD_ROOT/%{__frysk_libdir}/gtk-2.0/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/atk-1.0
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/cairo -I/usr/include/libgnomeui-2.0
-I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0
-I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2" "GNOME_LIBS =
-Wl,--export-dynamic -pthread -L/usr/X11R6/%{_lib} -lgnomeui-2 -lSM -lICE
-lbonoboui-2 -L/usr/%{_lib} -lxml2 -lpthread -lz -lgnome-2 -lpopt -lbonobo-2
-lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2 %{lib_gthread}
-lgnomecanvas-2 -lart_lgpl_2 %{lib_pangoft2} %{lib_gtk_x11} %{lib_gdk_x11}
%{lib_atk} -lgdk_pixbuf-2.0 -lm %{lib_pangocairo} %{lib_pango} %{lib_cairo}
%{lib_gobject} %{lib_gmodule} -ldl %{lib_glib}" "VTE_CFLAGS =
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/glib-2.0
-I$RPM_BUILD_ROOT/%{__frysk_libdir}/glib-2.0/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/gtk-2.0 -I/usr/include
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/pango-1.0 -I/usr/X11R6/include
-I/usr/include/freetype2 -I/usr/include/freetype2/config
-I$RPM_BUILD_ROOT/%{__frysk_libdir}/gtk-2.0/include
-I$RPM_BUILD_DIR/%{__frysk_includedir}/atk-1.0
-I$RPM_BUILD_ROOT/%{__frysk_includedir}/cairo" "VTE_LIBS = -L/usr/X11R6/%{_lib}
-L/usr/%{_lib} -lvte -lz -lncurses -lSM -lICE -lXft -lX11 -lfreetype -lXrender
%{lib_gtk_x11} %{lib_pangoxft} %{lib_pangox} %{lib_fontconfig} %{lib_gdk_x11}
%{lib_atk} %{lib_gdk_pixbuf} -lm %{lib_pangocairo} %{lib_cairo} %{lib_pangoft2}
%{lib_pango} %{lib_gobject} %{lib_gmodule} -ldl %{lib_glib}" "JGJAVA_CFLAGS =
%{JGJAVA_CFLAGS} -I $RPM_BUILD_ROOT/%{__frysk_includedir}"

It mainly deals with these library reference, making them to point to the
32-bits/64-bits specific ones.

For jpeg, expat, I don't know how to write a pkgconfig file for them, so I put
them as macros in function EXPORT.
Comment 1 Wu Zhou 2006-01-27 07:40:40 UTC
Oops. While installing the resulted binary rpm, it output the following messages:

[root@localhost SPECS]# rpm -ivh
/usr/src/redhat/RPMS/ppc64/frysk-0.0.1.2006.01.22-0.EL4.0.ppc64.rpm
Preparing...               ########################################### [100%]
   1:frysk                 ########################################### [100%]
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-cedilla.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-cedilla.so: cannot open shared object file:
No such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-cedilla.so does not export GTK+ IM module
API: /usr/lib/gtk-2.0/2.4.0/immodules/im-cedilla.so: cannot open shared object
file: No such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-viqr.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-viqr.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-viqr.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-viqr.so: cannot open shared object file: No
such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-iiim.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-iiim.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-iiim.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-iiim.so: cannot open shared object file: No
such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so: cannot open shared object
file: No such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so does not export GTK+ IM
module API: /usr/lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so: cannot open
shared object file: No such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ti-er.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ti-er.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-ti-er.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ti-er.so: cannot open shared object file: No
such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-am-et.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-am-et.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-am-et.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-am-et.so: cannot open shared object file: No
such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-inuktitut.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-inuktitut.so: cannot open shared object
file: No such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-inuktitut.so does not export GTK+ IM module
API: /usr/lib/gtk-2.0/2.4.0/immodules/im-inuktitut.so: cannot open shared object
file: No such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-xim.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-xim.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-xim.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-xim.so: cannot open shared object file: No
such file or directory
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ti-et.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ti-et.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-ti-et.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ti-et.so: cannot open shared object file: No
such file or directory
Cannot load module/ usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot open shared
object file: No such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so does not export GTK+ IM
module API: /usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot
open shared object file: No such file or directory


Don't know why it tried to load these modules under /usr/lib/gtk-2.0/.  All the
code in this binray rpm should be 64-bits code.


Start of resulted binary frysk also failed with the following message:

[root@localhost ~]# frysk
Exception in thread "main" java.lang.ExceptionInInitializerError
   at 0x0000008063ad6200 (Unknown Source)
   at 0x0000008063ad6258 (Unknown Source)
   at 0x0000008063aca914 (Unknown Source)
   at 0x0000008063ad05f0 (Unknown Source)
   at 0x0000008063ad3280 (Unknown Source)
   at 0x0000008063ad3414 (Unknown Source)
   at 0x000000806389f588 (Unknown Source)
   at 0x000000806389fd7c (Unknown Source)
   at 0x00000000100bf5a4 (Unknown Source)
   at 0x00000000100acaec (Unknown Source)
   at 0x00000000100a467c (Unknown Source)
   at 0x000000001009c34c (Unknown Source)
   at 0x0000000010099cac (Unknown Source)
   at 0x0000000010099ebc (Unknown Source)
   at 0x00000000100995fc (Unknown Source)
   at 0x000000806389547c (Unknown Source)
   at 0x00000080638e09ac (Unknown Source)
   at 0x00000080638aac24 (Unknown Source)
   at 0x000000806386079c (Unknown Source)
   at 0x0000008063860984 (Unknown Source)
   at 0x00000080638609d0 (Unknown Source)
   at 0x00000000100994f4 (Unknown Source)
   at 0x00000080898d415c (Unknown Source)
   at 0x00000080898d42e4 (Unknown Source)
Caused by: java.lang.NullPointerException
   at 0x0000008063ad6200 (Unknown Source)
   at 0x0000008063ad6258 (Unknown Source)
   at 0x0000008063aca914 (Unknown Source)
   at 0x0000008063acacb4 (Unknown Source)
   at 0x0000008063acacf0 (Unknown Source)
   at 0x0000008063acad20 (Unknown Source)
   at 0x0000008063acad80 (Unknown Source)
   at 0x000000806385f364 (Unknown Source)
   at 0x000001ffffffe6e0 (Unknown Source)
   at 0x00000080898630a4 (Unknown Source)
   at 0x00000080638b2e44 (Unknown Source)
   at 0x0000008063bbd974 (Unknown Source)
   at 0x00000000100f7020 (Unknown Source)
   at 0x00000000100e8184 (Unknown Source)
   at 0x000000806389f410 (Unknown Source)
   ...17 more


Can't get anything from these message.  

Any clues on these?  Will investigate them after I return back from vacation. 
Comment 2 Andrew Cagney 2006-01-27 19:38:42 UTC
FYI, I'll push a new rpm tonight (it was going to be last night but there was
some make distcheck borkage when trying to update the frysk tarball).  It built
on both ppc64 and x86-64.

This was included ...

< 	local c=" -mminimal-toc"
---
> 	local c=" -mminimal-toc -m64 "

I gather the remainder adds an explicit -L/usr/${_lib} such as ...

< %define pango_makeflags "%{glib_cflags}" "%{cairo_cflags}" "FONTCONFIG_LIBS =
%{lib_fontconfig}" "GLIB_LIBS = %{lib_gobject} %{lib_gmodule} %{lib_gthread}
%{lib_glib}" "CAIRO_LIBS = %{lib_cairo}" "XFT_CFLAGS =
-I$RPM_BUILD_ROOT/%{__frysk_includedir} -I/usr/X11R6/include
-I/usr/include/freetype2 -I/usr/include/freetype2/config" "XFT_LIBS =
-L/usr/X11R6/%{_lib} -lXft -lX11 -lfreetype -lXrender %{lib_fontconfig}"
---
> %define pango_makeflags "%{glib_cflags}" "%{cairo_cflags}" "FONTCONFIG_LIBS =
%{lib_fontconfig}" "GLIB_LIBS = %{lib_gobject} %{lib_gmodule} %{lib_gthread}
%{lib_glib}" "CAIRO_LIBS = %{lib_cairo}" "XFT_CFLAGS =
-I$RPM_BUILD_ROOT/%{__frysk_includedir} -I/usr/X11R6/include
-I/usr/include/freetype2 -I/usr/include/freetype2/config" "XFT_LIBS =
-L/usr/X11R6/%{_lib} -L/usr/%{_lib} -lXft -lX11 -lfreetype -lXrender
%{lib_fontconfig}"

... but that shouldn't be needed (my build certainly didn't) as a correctly
installed GCC will automatically adjust that.  I'm guessing this problem is due
to those library problems.
Comment 3 Wu Zhou 2006-02-08 09:49:03 UTC
Hi Andrew,

I had a try with the latest RHEL4 source rpm package (0128 version) on a PPC64
box (RHEL4 U3 beta1).  It still require these "-L/usr/lib64" explicitly set ready.  

And the above two problems ("cannot open shared object file" in the installation
phase of the binary rpm package and "Exception in thread "main"
java.lang.ExceptionInInitializerError" while starting frysk ) still exists after
the building.

I am now also suspecting that it is due to the library problems.  But my team
mates told me that they have been asking RedHat to have the same libraries
available for 64-bits as are available for 32-bits for 
at least two years.  But this request is not fulfilled yet.  Now that you are in
Redhat, would you please help us to see who in Redhat can help resolve this
problem for us?  

If you could help in this field, that will be highly appreciated!
Comment 4 Wu Zhou 2006-02-08 09:55:43 UTC
Andrew, 

another request: can you tell me how to create a same building / developing
environment as your are working on?  I believe that will help me a lot in the
frysk work.  

The things I am interested in include:

cpu type : x86, x86-64 or anything others
Linux release: FC4, FC5 or RHEL4, or anything else
Any additional packages or patches?
The process to build on ppc64?
......


Thanks a lot in advance.
Comment 5 Wu Zhou 2006-02-10 17:10:27 UTC
(In reply to comment #1)
> Oops. While installing the resulted binary rpm, it output the following messages:
> 
> [root@localhost SPECS]# rpm -ivh
> /usr/src/redhat/RPMS/ppc64/frysk-0.0.1.2006.01.22-0.EL4.0.ppc64.rpm
> Preparing...               ########################################### [100%]
>    1:frysk                 ########################################### [100%]
> Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so:
> /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
> such file or directory
.....
> /usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot
> open shared object file: No such file or directory
> 
> Don't know why it tried to load these modules under /usr/lib/gtk-2.0/.  All the
> code in this binray rpm should be 64-bits code.
> 

These message are spewed by /usr/bin/frysk-update-gtk-immodules:

#!/bin/sh
mkdir -p /etc/frysk/gtk-2.0/powerpc-redhat-linux-gnu
/usr/bin/frysk-gtk-query-immodules-2.0 >
/etc/frysk/gtk-2.0/powerpc-redhat-linux-gnu/gtk.immodules

[root@localhost BUILD]# /usr/bin/frysk-gtk-query-immodules-2.0
# GTK+ Input Method Modules file
# Automatically generated file, do not edit
# Created by /usr/bin/frysk-gtk-query-immodules-2.0 from gtk+-2.8.11
#
# ModulesPath =
/root/.gtk-2.0/2.4.0/powerpc-redhat-linux-gnu/immodules:/root/.gtk-2.0/2.4.0/immodules:/root/.gtk-2.0/powerpc-redhat-linux-gnu/immodules:/root/.gtk-2.0/immodules:/usr/lib/gtk-2.0/2.4.0/powerpc-redhat-linux-gnu/immodules:/usr/lib/gtk-2.0/2.4.0/immodules:/usr/lib/gtk-2.0/powerpc-redhat-linux-gnu/immodules:/usr/lib/gtk-2.0/immodules
#
Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
such file or directory
/usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so does not export GTK+ IM module API:
/usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
such file or directory
.....
/usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so does not export GTK+ IM
module API: /usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot
open shared object file: No such file or directory


Maybe it should handle these gtk-immodule under /usr/lib64 instead.
Comment 6 Andrew Cagney 2006-02-13 21:06:38 UTC
> > Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so:
> > /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
> > such file or directory
> .....
> > /usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot
> > open shared object file: No such file or directory
> > 
> > Don't know why it tried to load these modules under /usr/lib/gtk-2.0/.  All the
> > code in this binray rpm should be 64-bits code.
> > 
> 
> These message are spewed by /usr/bin/frysk-update-gtk-immodules:

ok
 
> #!/bin/sh
> mkdir -p /etc/frysk/gtk-2.0/powerpc-redhat-linux-gnu
> /usr/bin/frysk-gtk-query-immodules-2.0 >
> /etc/frysk/gtk-2.0/powerpc-redhat-linux-gnu/gtk.immodules
> 
> [root@localhost BUILD]# /usr/bin/frysk-gtk-query-immodules-2.0
> # GTK+ Input Method Modules file
> # Automatically generated file, do not edit
> # Created by /usr/bin/frysk-gtk-query-immodules-2.0 from gtk+-2.8.11
> #
> # ModulesPath =
>
/root/.gtk-2.0/2.4.0/powerpc-redhat-linux-gnu/immodules:/root/.gtk-2.0/2.4.0/immodules:/root/.gtk-2.0/powerpc-redhat-linux-gnu/immodules:/root/.gtk-2.0/immodules:/usr/lib/gtk-2.0/2.4.0/powerpc-redhat-linux-gnu/immodules:/usr/lib/gtk-2.0/2.4.0/immodules:/usr/lib/gtk-2.0/powerpc-redhat-linux-gnu/immodules:/usr/lib/gtk-2.0/immodules
> #
> Cannot load module /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so:
> /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
> such file or directory
> /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so does not export GTK+ IM module API:
> /usr/lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No
> such file or directory
> .....
> /usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so does not export GTK+ IM
> module API: /usr/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot
> open shared object file: No such file or directory
> 
> 
> Maybe it should handle these gtk-immodule under /usr/lib64 instead.

yes.

- the program /usr/bin/frysk-gtk-query-immodules-2.0 has, somehow or other got
<<lib>>, instead of <<lib64>> wired into its module search path.

- the script is writing the output to powerpc-redhat-linux-gnu instead of
powerpc64-redhat-linux-gnu

perhaphs look at fc5 to see if anything significant is different in its gtk rpm?
Comment 7 Wu Zhou 2006-02-14 08:37:03 UTC
I managed to build Frysk on a FC5-test2 / PPC64 box (with some trick to get
64-bit library from download.redhat.com rpm tree).

The resulted frysk package can installed gracefully on PPC64.  And I can also
start frysk without any problem. 

But when I try to add a terminating observer to a top process, it reported the
following error message:

15-Feb-06 5:36:36 AM frysk.gui.Gui null
WARNING: /root/.frysk/.settings not found. Will be created on program exit
./frysk-gui/frysk/gui/FryskGui: symbol lookup error:
/root/DE-Frysk/frysk-cvs/latest-cvs/build/frysk-gui/../frysk-gtk/tlwidgets/libftk.so:
undefined symbol: timer_create
Comment 8 Andrew Cagney 2006-05-05 17:56:28 UTC
64-bit build problem has been resolved; The timer_create call has been
eliminated in the latest sources.