Bug 2206 - 20060123 Build Error on Sparc - Math Build Problem
Summary: 20060123 Build Error on Sparc - Math Build Problem
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: math (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Andreas Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-25 14:29 UTC by Jim Gifford
Modified: 2006-02-03 16:02 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Gifford 2006-01-25 14:29:00 UTC
Last snapshot tested on this machine was 20060116, no issues. Trying to isolate
the actual change that affected this. Here is the errors.

sparc64-unknown-linux-gnu-gcc -mcpu=ultrasparc -mtune=ultrasparc -mvis -m32  
-shared -static-libgcc -Wl,-O1  -Wl,-z,defs
-Wl,-dynamic-linker=/tools/lib/ld-linux.so.2 
-B/mnt/netra/build/glibc-cross-32bit/csu/ 
-Wl,--version-script=/mnt/netra/build/glibc-cross-32bit/libm.map
-Wl,-soname=libm.so.6 -Wl,-z,combreloc -Wl,-z,relro 
-L/mnt/netra/build/glibc-cross-32bit -L/mnt/netra/build/glibc-cross-32bit/math
-L/mnt/netra/build/glibc-cross-32bit/elf
-L/mnt/netra/build/glibc-cross-32bit/dlfcn
-L/mnt/netra/build/glibc-cross-32bit/nss
-L/mnt/netra/build/glibc-cross-32bit/nis -L/mnt/netra/build/glibc-cross-32bit/rt
-L/mnt/netra/build/glibc-cross-32bit/resolv
-L/mnt/netra/build/glibc-cross-32bit/crypt
-L/mnt/netra/build/glibc-cross-32bit/nptl
-Wl,-rpath-link=/mnt/netra/build/glibc-cross-32bit:/mnt/netra/build/glibc-cross-32bit/math:/mnt/netra/build/glibc-cross-32bit/elf:/mnt/netra/build/glibc-cross-32bit/dlfcn:/mnt/netra/build/glibc-cross-32bit/nss:/mnt/netra/build/glibc-cross-32bit/nis:/mnt/netra/build/glibc-cross-32bit/rt:/mnt/netra/build/glibc-cross-32bit/resolv:/mnt/netra/build/glibc-cross-32bit/crypt:/mnt/netra/build/glibc-cross-32bit/nptl
-o /mnt/netra/build/glibc-cross-32bit/math/libm.so -T
/mnt/netra/build/glibc-cross-32bit/shlib.lds
/mnt/netra/build/glibc-cross-32bit/csu/abi-note.o -Wl,--whole-archive
/mnt/netra/build/glibc-cross-32bit/math/libm_pic.a -Wl,--no-whole-archive
/mnt/netra/build/glibc-cross-32bit/elf/interp.os
/mnt/netra/build/glibc-cross-32bit/libc.so
/mnt/netra/build/glibc-cross-32bit/libc_nonshared.a
/mnt/netra/build/glibc-cross-32bit/math/libm_pic.a(s_ctanl.os): In function
`__ctanl':
../math/s_ctanl.c:68: undefined reference to `__multc3'
../math/s_ctanl.c:70: undefined reference to `__divtc3'
../math/s_ctanl.c:70: undefined reference to `__multc3'
/mnt/netra/build/glibc-cross-32bit/math/libm_pic.a(s_ctanhl.os): In function
`__ctanhl':
../math/s_ctanhl.c:69: undefined reference to `__divtc3'
/mnt/netra/build/glibc-cross-32bit/math/libm_pic.a(s_cpowl.os): In function
`__cpowl':
../math/s_cpowl.c:28: undefined reference to `__multc3'
collect2: ld returned 1 exit status
make[2]: *** [/mnt/netra/build/glibc-cross-32bit/math/libm.so] Error 1
make[2]: Leaving directory `/mnt/netra/build/glibc-20060123/math'
make[1]: *** [math/others] Error 2
make[1]: Leaving directory `/mnt/netra/build/glibc-20060123'
make: *** [all] Error 2
Comment 1 Roland McGrath 2006-01-25 18:53:21 UTC

*** This bug has been marked as a duplicate of 333 ***
Comment 2 Jim Gifford 2006-01-27 16:56:36 UTC
Current Sparc will not build the current glibc snapshot. I'm working through all
the patches to determine which one is the culprit. The last knowing working
glibcsnapshot was beleived to be 20060116, but it's 20060109. As soon as I can
figure out what the culprit is and correct that I will submit a patch via this
bz. It a very strange error and needs to be looked at. I would request this bug
to reopened.
Comment 3 Jim Gifford 2006-01-30 15:32:22 UTC
Now further testing shows that 64 bit build of glibc fails as well.
sparc64-unknown-linux-gnu-gcc -mcpu=ultrasparc -mtune=ultrasparc -mvis -m64
unwind.c -c -std=gnu99 -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants
-g -Wstrict-prototypes -fcall-used-g6  -fexceptions   -I../include
-I/mnt/netra/build/glibc-cross-64bit/nptl -I/mnt/netra/build/glibc-cross-64bit
-I../sysdeps/sparc/sparc64/elf -I../nptl/sysdeps/unix/sysv/linux/sparc/sparc64
-I../sysdeps/unix/sysv/linux/sparc/sparc64
-I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux/sparc
-I../sysdeps/unix/sysv/linux/sparc -I../nptl/sysdeps/unix/sysv/linux
-I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux
-I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman
-I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv
-I../sysdeps/unix/sparc -I../libidn/sysdeps/unix -I../nptl/sysdeps/unix
-I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/sparc/sparc64/fpu
-I../nptl/sysdeps/sparc/sparc64 -I../sysdeps/sparc/sparc64
-I../sysdeps/wordsize-64 -I../sysdeps/ieee754/ldbl-128
-I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32
-I../sysdeps/sparc/sparc64/soft-fp -I../sysdeps/sparc/fpu
-I../nptl/sysdeps/sparc -I../sysdeps/sparc -I../nptl/sysdeps/generic
-I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I..
-I../libio  -I. -nostdinc -isystem
/mnt/netra/cross-tools/bin/../lib/gcc/sparc64-unknown-linux-gnu/4.0.2/include
-isystem /tools/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  
-DNOT_IN_libc=1 -DIS_IN_libpthread=1    -o
/mnt/netra/build/glibc-cross-64bit/nptl/unwind.o -MD -MP -MF
/mnt/netra/build/glibc-cross-64bit/nptl/unwind.o.dt -MT
/mnt/netra/build/glibc-cross-64bit/nptl/unwind.o
In file included from unwind.c:26:
../sysdeps/sparc/sparc64/jmpbuf-unwind.h:21:28: error: jmpbuf-offsets.h: No such
file or directory
make[2]: *** [/mnt/netra/build/glibc-cross-64bit/nptl/unwind.o] Error 1
make[2]: Leaving directory `/mnt/netra/build/glibc-20060123/nptl'
make[1]: *** [nptl/subdir_lib] Error 2
make[1]: Leaving directory `/mnt/netra/build/glibc-20060123'
make: *** [all] Error 2
Comment 4 Jim Gifford 2006-01-30 15:33:09 UTC
It seems all the changes to the ieee754 has affected the Sparc build, you can no
longer make glibc on a sparc do to these changes.
Comment 5 Jim Gifford 2006-01-31 19:03:51 UTC
Sparc 32 is corrected by this patch
http://sources.redhat.com/ml/libc-hacker/2006-01/msg00104.html

Sparc 64 still has a missing header. jmpbuf-offsets.h
Comment 6 Jim Gifford 2006-02-01 04:14:09 UTC
Sparc 64 bit builds with the addition of the patch from libc-hacker list
http://sources.redhat.com/ml/libc-hacker/2006-01/msg00105.html

but still fails to compile due to this error.

sparc64-unknown-linux-gnu-gcc -mcpu=ultrasparc -mtune=ultrasparc -mvis -m64  
-shared -static-libgcc -Wl,-O1  -Wl,-z,defs
-Wl,-dynamic-linker=/tools/lib64/ld-linux.so.2 
-B/mnt/netra/build/glibc-cross-64bit/csu/ 
-Wl,--version-script=/mnt/netra/build/glibc-cross-64bit/libc.map
-Wl,-soname=libc.so.6 -Wl,-z,combreloc -Wl,-z,relro -nostdlib -nostartfiles -e
__libc_main -L/mnt/netra/build/glibc-cross-64bit
-L/mnt/netra/build/glibc-cross-64bit/math
-L/mnt/netra/build/glibc-cross-64bit/elf
-L/mnt/netra/build/glibc-cross-64bit/dlfcn
-L/mnt/netra/build/glibc-cross-64bit/nss
-L/mnt/netra/build/glibc-cross-64bit/nis -L/mnt/netra/build/glibc-cross-64bit/rt
-L/mnt/netra/build/glibc-cross-64bit/resolv
-L/mnt/netra/build/glibc-cross-64bit/crypt
-L/mnt/netra/build/glibc-cross-64bit/nptl
-Wl,-rpath-link=/mnt/netra/build/glibc-cross-64bit:/mnt/netra/build/glibc-cross-64bit/math:/mnt/netra/build/glibc-cross-64bit/elf:/mnt/netra/build/glibc-cross-64bit/dlfcn:/mnt/netra/build/glibc-cross-64bit/nss:/mnt/netra/build/glibc-cross-64bit/nis:/mnt/netra/build/glibc-cross-64bit/rt:/mnt/netra/build/glibc-cross-64bit/resolv:/mnt/netra/build/glibc-cross-64bit/crypt:/mnt/netra/build/glibc-cross-64bit/nptl
-o /mnt/netra/build/glibc-cross-64bit/libc.so -T
/mnt/netra/build/glibc-cross-64bit/shlib.lds
/mnt/netra/build/glibc-cross-64bit/csu/abi-note.o
/mnt/netra/build/glibc-cross-64bit/elf/soinit.os
/mnt/netra/build/glibc-cross-64bit/libc_pic.os
/mnt/netra/build/glibc-cross-64bit/elf/sofini.os
/mnt/netra/build/glibc-cross-64bit/elf/interp.os
/mnt/netra/build/glibc-cross-64bit/elf/ld.so -lgcc
/mnt/netra/cross-tools/bin/../lib/gcc/sparc64-unknown-linux-gnu/4.0.2/../../../../sparc64-unknown-linux-gnu/bin/ld:
/mnt/netra/build/glibc-cross-64bit/libc_pic.os: check_relocs: unhandled reloc
type 67
/mnt/netra/build/glibc-cross-64bit/libc_pic.os: could not read symbols: File
format not recognized
collect2: ld returned 1 exit status
make[1]: *** [/mnt/netra/build/glibc-cross-64bit/libc.so] Error 1
Comment 7 Jim Gifford 2006-02-03 16:02:52 UTC
Was able to build with all Jakub's patches from 1-31-2006 to 2-2-2006. Closing