Bug 2151 - Need method to specify debug search path
Summary: Need method to specify debug search path
Status: RESOLVED FIXED
Alias: None
Product: systemtap
Classification: Unclassified
Component: translator (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Frank Ch. Eigler
URL:
Keywords:
: 5005 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-13 06:23 UTC by Josh Stone
Modified: 2008-01-23 23:42 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Stone 2006-01-13 06:23:46 UTC
Some systems do not have debug binaries in the "standard" locations.  The
elfutils library can be made to customize the search path; what is needed first
is a way to indicate that through stap.  This could be command-line options, or
perhaps an environment variable (perhaps SYSTEMTAP_DEBUG_PATH).  

see also http://sourceware.org/ml/systemtap/2006-q1/msg00111.html
Comment 1 bibo,mao 2006-01-13 06:45:58 UTC
Configration file is also another way, that can define module debug info path, 
MAXACTION etc.
Comment 2 Thang Nguyen 2006-05-01 18:25:20 UTC
Reassigned this to the group.  Anyone else want to try, please do.
Comment 3 Josh Stone 2007-09-07 16:15:34 UTC
*** Bug 5005 has been marked as a duplicate of this bug. ***
Comment 4 Frank Ch. Eigler 2008-01-23 19:23:24 UTC
About time.
Comment 5 Frank Ch. Eigler 2008-01-23 23:42:31 UTC
patch committed at long last. $SYSTEMTAP_DEBUGINFO_PATH