Bug 2124 - rtld_global undefined errors in dl* sources
Summary: rtld_global undefined errors in dl* sources
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.6
: P2 normal
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-08 03:26 UTC by Chris White
Modified: 2006-01-08 03:27 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: Build triplet
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris White 2006-01-08 03:26:01 UTC
Compiling glibc-2.3.6 with gcc-3.3.6:  
  
 /var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl_pic.a(dlsym.os): 
In function `dlsym': 
dlsym.c:(.text+0x65): undefined reference to `_rtld_global' 
/var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl_pic.a(dlvsym.os): 
In function `dlvsym': 
dlvsym.c:(.text+0x75): undefined reference to `_rtld_global' 
/var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl_pic.a(dlerror.os): 
In function `_dlerror_run': 
dlerror.c:(.text+0x2a7): undefined reference to `_rtld_global_ro' 
/var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl_pic.a(dlinfo.os): 
In function `.L4': 
dlinfo.c:(.text+0x41): undefined reference to `_rtld_global_ro' 
/var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl_pic.a(dlinfo.os): 
In function `.L7': 
dlinfo.c:(.text+0x73): undefined reference to `_dl_rtld_di_serinfo' 
/var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl_pic.a(dlmopen.os): 
In function `dlmopen_doit': 
dlmopen.c:(.text+0x6f): undefined reference to `_rtld_global_ro' 
collect2: ld returned 1 exit status 
make[2]: *** 
[/var/tmp/portage/glibc-2.3.6-r1/work/build-default-i686-pc-linux-gnu-nptl/dlfcn/libdl.so] 
Error 1 
make[2]: Leaving directory 
`/var/tmp/portage/glibc-2.3.6-r1/work/glibc-2.3.6/malloc' 
make[1]: *** [malloc/others] Error 2 
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.6-r1/work/glibc-2.3.6' 
make: *** [all] Error 2 
 
Configure options used: 
 
 * Configuring GLIBC for nptl with: 
                --disable-dev-erandom 
                --with-tls 
                --with-__thread 
                --enable-add-ons=nptl,c_stubs,libidn 
                --enable-kernel=2.6.6 
                --without-selinux 
                --without-cvs 
                --enable-bind-now 
                --build=i686-pc-linux-gnu 
                --host=i686-pc-linux-gnu 
                --disable-profile 
                --without-gd 
                --with-headers=/usr/include 
                --prefix=/usr 
                --mandir=/usr/share/man 
                --infodir=/usr/share/info 
                --libexecdir=/usr/lib/misc/glibc
Comment 1 Roland McGrath 2006-01-08 03:27:09 UTC

*** This bug has been marked as a duplicate of 333 ***