Bug 2030 - Pango-CRITICAL **: _pango_engine_shape_shape: assertion `PANGO_IS_FONT (font)' failed
Summary: Pango-CRITICAL **: _pango_engine_shape_shape: assertion `PANGO_IS_FONT (font)...
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P1 normal
Target Milestone: ---
Assignee: Andrew Cagney
URL:
Keywords:
Depends on: 2029
Blocks: 2004
  Show dependency treegraph
 
Reported: 2005-12-11 19:56 UTC by Andrew Cagney
Modified: 2005-12-12 14:28 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Cagney 2005-12-11 19:56:15 UTC
frysk-0.0.0.20051211.1-0.EL4.1

(java-gnome:9880): Pango-CRITICAL **: _pango_engine_shape_shape: assertion
`PANGO_IS_FONT (font)' failed

Pango-ERROR **: file
/notnfs/cagney/wip/frysk/RHEL-4/frysk-0.0.0.20051211.1/pango-1.10.0/pango/shape.c:
line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)
aborting...
Aborted

----

This is part of the longer message:

(java-gnome:9880): Pango-WARNING **: No builtin or dynamically loaded modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
  '/etc/frysk/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.

(java-gnome:9880): Pango-CRITICAL **: _pango_engine_shape_shape: assertion
`PANGO_IS_FONT (font)' failed

Pango-ERROR **: file
/notnfs/cagney/wip/frysk/RHEL-4/frysk-0.0.0.20051211.1/pango-1.10.0/pango/shape.c:
line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)
aborting...
Aborted
Comment 1 Andrew Cagney 2005-12-12 14:28:07 UTC
Problem caused by lack of pango modules file, adding that fixes this.