Bug 1860 - binutils.texi:3495: No such file or directory.
Summary: binutils.texi:3495: No such file or directory.
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: binutils (show other bugs)
Version: 2.17
: P2 minor
Target Milestone: ---
Assignee: unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-12 16:18 UTC by John David Anglin
Modified: 2006-03-31 02:33 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John David Anglin 2005-11-12 16:18:37 UTC
Making info in doc
make[3]: Entering directory `/home/dave/binutils-2.16.91/objdir/binutils/doc'
rm -f config.texi
eval `grep '^ *VERSION=' ../../../src/binutils/doc/../../bfd/configure`; \
  echo "@set VERSION $VERSION" > config.texi
echo "@set UPDATED `date "+%B %Y"`" >> config.texi
echo "@set top_srcdir ../../../src/binutils" >> config.texi
restore=: && backupdir=".am$$" && \
am__cwd=`pwd` && cd ../../../src/binutils/doc && \
rm -rf $backupdir && mkdir $backupdir && \
for f in ../../../src/binutils/doc/binutils.info ../../../src/binutils/doc/binut
ils.info-[0-9] ../../../src/binutils/doc/binutils.info-[0-9][0-9] ../../../src/b
inutils/doc/binutils.i[0-9] ../../../src/binutils/doc/binutils.i[0-9][0-9]; do \
  if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
done; \
cd "$am__cwd"; \
if makeinfo --split-size=5000000 --split-size=5000000   -I ../../../src/binutils
/doc \
 -o ../../../src/binutils/doc/binutils.info ../../../src/binutils/doc/binutils.t
exi; \
then \
  rc=0; \
  cd ../../../src/binutils/doc; \
else \
  rc=$?; \
  cd ../../../src/binutils/doc && \
  $restore $backupdir/* `echo "./../../../src/binutils/doc/binutils.info" | sed
's|[^/]*$||'`; \
fi; \
rm -rf $backupdir; exit $rc
../../../src/binutils/doc/binutils.texi:3495: @include `@value{top_srcdir}/../li
biberty/at-file.texi': No such file or directory.
makeinfo: Removing output file `../../../src/binutils/doc/binutils.info' due to
errors; use --force to preserve.
make[3]: *** [../../../src/binutils/doc/binutils.info] Error 2

The configure command was:

../src/configure --prefix=/home/dave/opt/gnu --host=hppa-linux --target=hppa64-
linux --disable-nls &&

Doesn't happen when not doing a cross.
Comment 1 Hans-Peter Nilsson 2005-11-12 20:27:33 UTC
Subject: Re:  New: binutils.texi:3495: No such file or
 directory.

On Sat, 12 Nov 2005, danglin at gcc dot gnu dot org wrote:
> ../../../src/binutils/doc/binutils.texi:3495: @include `@value{top_srcdir}/../li
> biberty/at-file.texi': No such file or directory.

> ../src/configure --prefix=/home/dave/opt/gnu --host=hppa-linux --target=hppa64-
> linux --disable-nls &&
>
> Doesn't happen when not doing a cross.

Don't know why *that* case is different, but for the
status on the makeinfo breakage, see
<URL:http://sourceware.org/ml/binutils/2005-11/msg00131.html>
and linked messages.

brgds, H-P
Comment 2 dave@hiauly1.hia.nrc.ca 2005-11-12 20:45:43 UTC
Subject: Re:  binutils.texi:3495: No such file or directory.

> > Doesn't happen when not doing a cross.
> 
> Don't know why *that* case is different, but for the

Different PATHs caused different versions of makeinfo to get selected.

Dave
Comment 3 H.J. Lu 2005-12-22 17:08:52 UTC
It works for me.
Comment 4 dave@hiauly1.hia.nrc.ca 2005-12-22 18:26:28 UTC
Subject: Re:  binutils.texi:3495: No such file or directory.

> ------- Additional Comments From hjl at lucon dot org  2005-12-22 17:08 -------
> It works for me.

This was caused by using an old version of makeinfo.  There needed to be
an update somewhere to ensure that a sufficiently recent version was
available.  That's why the PR wasn't closed.

Dave
Comment 5 Hans-Peter Nilsson 2005-12-23 03:30:34 UTC
Reopening; still not fixed.
Needs a makeinfo >= 4.2 < 4.5 (?) to repeat the behavior.
Comment 6 Ben Elliston 2006-03-31 02:05:26 UTC
I have examined the problem more extensively.  The problem exists up to Texinfo
version 4.3 (and point releases of 4.3).  Texinfo 4.4 adds the necessary support
for @include @value and is now the minimum required version.

Texinfo 4.2 was released on 1 April 2002.
Texinfo 4.3 was released on 14 November 2002.
Texinfo 4.4 was released in 31 January 2003.

I think that raising the minimum requirement on Texinfo to version 4.4 is quite
safe.  I will submit a patch.
Comment 7 dave@hiauly1.hia.nrc.ca 2006-03-31 02:06:47 UTC
Subject: Re:  binutils.texi:3495: No such file or directory.

> I think that raising the minimum requirement on Texinfo to version 4.4 is quite
> safe.  I will submit a patch.

Thanks.

Dave
Comment 8 Ben Elliston 2006-03-31 02:18:27 UTC
A patch is posted at:
  http://sourceware.org/ml/binutils/2006-03/msg00364.html
Comment 9 Ben Elliston 2006-03-31 02:33:32 UTC
Fixed:

2006-03-31  Ben Elliston  <bje@au.ibm.com>

        PR binutils/1860
        * configure.in: Require makeinfo 4.4 or higher.
        * configure: Regenerate.

Checking in configure.in;
/cvs/src/src/configure.in,v  <--  configure.in
new revision: 1.302; previous revision: 1.301
done
Checking in configure;
/cvs/src/src/configure,v  <--  configure
new revision: 1.215; previous revision: 1.214
done