Bug 18521 - failing tests on fedora 22
Summary: failing tests on fedora 22
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: gold (show other bugs)
Version: 2.26
: P2 normal
Target Milestone: 2.26
Assignee: Cary Coutant
URL:
Keywords:
Depends on: 18628 18663
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-11 21:20 UTC by Rafael Ávila de Espíndola
Modified: 2015-07-22 10:45 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
A self contained testcase of one of the test failures (1.78 MB, application/x-bzip2)
2015-06-13 18:53 UTC, Rafael Ávila de Espíndola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Ávila de Espíndola 2015-06-11 21:20:12 UTC
I just installed fedora 22 on a VM and I am getting the following test failures on
5d7908e0880030628536a0266968a15922574735:


========================================
   gold 0.1: testsuite/test-suite.log   
========================================

9 of 222 tests failed.  

.. contents:: :depth: 2


FAIL: script_test_1 (exit: 134)
===============================

script_test_1: ../../../binutils/gold/testsuite/script_test_1.cc:42: int main(int, char**): Assertion `reinterpret_cast<int*>(&e) == &sym' failed.

FAIL: script_test_11 (exit: 2)
==============================


FAIL: ifuncmain1 (exit: 139)
============================


FAIL: ifuncmain1pic (exit: 139)
===============================


FAIL: ifuncmain1vis (exit: 139)
===============================


FAIL: ifuncmain1vispic (exit: 139)
==================================


FAIL: ifuncmain1pie (exit: 139)
===============================


FAIL: ifuncmain1vispie (exit: 139)
==================================


FAIL: ifuncmain3 (exit: 139)
============================
Comment 1 Rafael Ávila de Espíndola 2015-06-13 18:53:30 UTC
Created attachment 8361 [details]
A self contained testcase of one of the test failures
Comment 2 Cary Coutant 2015-07-22 02:14:38 UTC
*** Bug 18628 has been marked as a duplicate of this bug. ***
Comment 3 Cary Coutant 2015-07-22 02:16:38 UTC
*** Bug 18663 has been marked as a duplicate of this bug. ***
Comment 4 H.J. Lu 2015-07-22 02:17:55 UTC
Dup.

*** This bug has been marked as a duplicate of bug 18628 ***
Comment 5 Cary Coutant 2015-07-22 02:28:43 UTC
Sigh. This bug isn't really a duplicate of PR 18628 (it's really 18268 that duplicates a subset of this one). Let's consider this bug split into PR 18628 (for the IFUNC failures) and PR 18863 (for the script_test failures).
Comment 6 H.J. Lu 2015-07-22 02:37:42 UTC
Reopen
Comment 7 H.J. Lu 2015-07-22 10:45:48 UTC
Fixed.