Bug 17468 - syscalls not recorded with arch (or some such)
Summary: syscalls not recorded with arch (or some such)
Status: RESOLVED DUPLICATE of bug 10737
Alias: None
Product: gdb
Classification: Unclassified
Component: breakpoints (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-08 16:27 UTC by dje
Modified: 2014-10-08 19:13 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dje 2014-10-08 16:27:35 UTC
I happened to stumble on this.

On amd64, where there is an "accept" syscall for amd64 but not i386 (at least not in the xml file)

$ make run
(gdb) catch syscall accept
Unknown syscall name 'accept'.
(gdb) file ~/hello.x64
...
(gdb) catch syscall accept.
Unknown syscall name 'accept'.

Start over and select the executable first.

$ make run
(gdb) file ~/hello.x64
...
(gdb) catch syscall accept
Catchpoint 1 ...

The syscall file name is stored in a global, as a record of whether it has been loaded, and once set is assumed to be ok for life.
This should be recorded with the arch or some such.
Comment 1 Sergio Durigan Junior 2014-10-08 19:10:38 UTC
There is already a bug for this (I am taking care of it).  I am closing as duplicate.

*** This bug has been marked as a duplicate of bug 10737 ***
Comment 2 dje 2014-10-08 19:13:17 UTC
(In reply to Sergio Durigan Junior from comment #1)
> There is already a bug for this (I am taking care of it).  I am closing as
> duplicate.
> 
> *** This bug has been marked as a duplicate of bug 10737 ***

Thanks.  I had hoped bugzilla would give me the existing CL while I was filing it (like it tries to do).  Oh well, no worries.