Bug 17206 - Assertion `pc_in_thread_step_range (pc, tp)' failed.
Summary: Assertion `pc_in_thread_step_range (pc, tp)' failed.
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: 7.7
: P2 normal
Target Milestone: 7.8
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-27 19:14 IST by Tillmann Karras
Modified: 2014-07-29 06:42 IST (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tillmann Karras 2014-07-27 19:14:49 IST
After a SIGSEGV, I accidentally typed 'u' (until) instead of 'up' and got this: 

$ echo 'int main(){return*(int*)0;}'|gcc -xc - && gdb -ex r a.out
Program received signal SIGSEGV, Segmentation fault.
(gdb) u
infrun.c:1948: internal-error: resume: Assertion `pc_in_thread_step_range (pc, tp)' failed.

(output shortened)

GDB 7.7.1 on Arch Linux x86_64 testing.
Comment 1 Doug Evans 2014-07-27 19:18:23 IST
Repro'd with 7.8 branch as of today.

It didn't repro with 7.6.1-46.fc19
Comment 2 Yao Qi 2014-07-28 06:19:26 IST
The reproducer can be simpler,

$ cat 2.c 
int
main(void)
{
  return 0;
}

$ gcc 2.c -o 2.exe

(gdb) b main
Breakpoint 1 at 0x8048403
(gdb) run
Starting program: /home/yao/Source/gnu/gdb/build-git/2.exe 

Breakpoint 1, 0x08048403 in main ()
(gdb) until 
0x08048408 in main ()
(gdb) until
../../../git/gdb/infrun.c:1992: internal-error: resume: Assertion `pc_in_thread_step_range (pc, tp)' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) y

I have a patch which is being regression tested.  I'll post it once the regression test is finished.
Comment 3 cvs-commit@gcc.gnu.org 2014-07-29 04:05:22 IST
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  7e09a22367934a6d53f79d8b01135832b80ab246 (commit)
      from  7ebdbe9292e4b696740b021938369adb1484da27 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=7e09a22367934a6d53f79d8b01135832b80ab246

commit 7e09a22367934a6d53f79d8b01135832b80ab246
Author: Yao Qi <yao@codesourcery.com>
Date:   Mon Jul 28 13:44:57 2014 +0800

    Fix PR 17206
    
    As reported in PR 17206, an internal error is triggered when command
    until is executed.  In infcmd.c:until_next_command, step_range_end is
    set to 'pc',
    
      if (!func)
        {
          struct bound_minimal_symbol msymbol = lookup_minimal_symbol_by_pc (pc);
    
          if (msymbol.minsym == NULL)
    	error (_("Execution is not within a known function."));
    
          tp->control.step_range_start = BMSYMBOL_VALUE_ADDRESS (msymbol);
          tp->control.step_range_end = pc;
        }
    
    and later in infrun.c:resume, the assert below is triggered in PR
    17206.
    
      if (tp->control.may_range_step)
        {
          /* If we're resuming a thread with the PC out of the step
    	 range, then we're doing some nested/finer run control
    	 operation, like stepping the thread out of the dynamic
    	 linker or the displaced stepping scratch pad.  We
    	 shouldn't have allowed a range step then.  */
          gdb_assert (pc_in_thread_step_range (pc, tp));
        }
    
    In until_next_command, we set step range to [XXX, pc), so pc isn't
    within the range.  pc_in_thread_step_range returns false and the
    assert is triggered.  AFAICS, the range we want in until_next_command
    is [XXX, pc] instead of [XXX, pc), because we want to program step
    until greater than pc.  This patch is to set step_range_end to
    'pc + 1'.  Running until-nodebug.exp with unpatched GDB will get the
    following fail,
    
    FAIL: gdb.base/until-nodebug.exp: until 2 (GDB internal error)
    
    and the fail goes away when the fix is applied.
    
    gdb:
    
    2014-07-29  Yao Qi  <yao@codesourcery.com>
    
    	PR gdb/17206
    	* infcmd.c (until_next_command): Set step_range_end to PC + 1.
    
    gdb/testsuite:
    
    2014-07-29  Yao Qi  <yao@codesourcery.com>
    
    	PR gdb/17206
    	* gdb.base/until-nodebug.exp: New.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog                                      |    5 ++++
 gdb/infcmd.c                                       |    4 ++-
 gdb/testsuite/ChangeLog                            |    5 ++++
 .../{source-execution.exp => until-nodebug.exp}    |   24 +++++++++++--------
 4 files changed, 27 insertions(+), 11 deletions(-)
 copy gdb/testsuite/gdb.base/{source-execution.exp => until-nodebug.exp} (60%)
Comment 4 cvs-commit@gcc.gnu.org 2014-07-29 06:36:30 IST
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, gdb-7.8-branch has been updated
       via  f7f4b7afaa717a83e9eaf157a8870c99978f2942 (commit)
      from  c201aa9323dc01f782d1db2607aa9e69d6bf90df (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=f7f4b7afaa717a83e9eaf157a8870c99978f2942

commit f7f4b7afaa717a83e9eaf157a8870c99978f2942
Author: Yao Qi <yao@codesourcery.com>
Date:   Mon Jul 28 13:44:57 2014 +0800

    Fix PR 17206
    
    As reported in PR 17206, an internal error is triggered when command
    until is executed.  In infcmd.c:until_next_command, step_range_end is
    set to 'pc',
    
      if (!func)
        {
          struct bound_minimal_symbol msymbol = lookup_minimal_symbol_by_pc (pc);
    
          if (msymbol.minsym == NULL)
    	error (_("Execution is not within a known function."));
    
          tp->control.step_range_start = BMSYMBOL_VALUE_ADDRESS (msymbol);
          tp->control.step_range_end = pc;
        }
    
    and later in infrun.c:resume, the assert below is triggered in PR
    17206.
    
      if (tp->control.may_range_step)
        {
          /* If we're resuming a thread with the PC out of the step
    	 range, then we're doing some nested/finer run control
    	 operation, like stepping the thread out of the dynamic
    	 linker or the displaced stepping scratch pad.  We
    	 shouldn't have allowed a range step then.  */
          gdb_assert (pc_in_thread_step_range (pc, tp));
        }
    
    In until_next_command, we set step range to [XXX, pc), so pc isn't
    within the range.  pc_in_thread_step_range returns false and the
    assert is triggered.  AFAICS, the range we want in until_next_command
    is [XXX, pc] instead of [XXX, pc), because we want to program step
    until greater than pc.  This patch is to set step_range_end to
    'pc + 1'.  Running until-nodebug.exp with unpatched GDB will get the
    following fail,
    
    FAIL: gdb.base/until-nodebug.exp: until 2 (GDB internal error)
    
    and the fail goes away when the fix is applied.
    
    gdb:
    
    2014-07-29  Yao Qi  <yao@codesourcery.com>
    
    	PR gdb/17206
    	* infcmd.c (until_next_command): Set step_range_end to PC + 1.
    
    gdb/testsuite:
    
    2014-07-29  Yao Qi  <yao@codesourcery.com>
    
    	PR gdb/17206
    	* gdb.base/until-nodebug.exp: New.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog                                      |    5 ++++
 gdb/infcmd.c                                       |    4 ++-
 gdb/testsuite/ChangeLog                            |    5 ++++
 .../{source-execution.exp => until-nodebug.exp}    |   24 +++++++++++--------
 4 files changed, 27 insertions(+), 11 deletions(-)
 copy gdb/testsuite/gdb.base/{source-execution.exp => until-nodebug.exp} (60%)
Comment 5 Yao Qi 2014-07-29 06:42:34 IST
Patch is pushed in.  Close it.