Bug 17177 - Replace *pretty-printers* global with access functions
Summary: Replace *pretty-printers* global with access functions
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: guile (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-18 13:14 UTC by dje
Modified: 2014-07-28 01:07 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dje 2014-07-18 13:14:22 UTC
Instead of exporting the list of global pretty-printers as a global variable, we should export functions to get/set the value.
Comment 1 cvs-commit@gcc.gnu.org 2014-07-26 22:00:50 UTC
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  ee7333ae06f46f3a6909a0059c2f0bd441a54bfe (commit)
      from  74edf51613b507d1f27d66360cd8fdd8a253e88a (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=ee7333ae06f46f3a6909a0059c2f0bd441a54bfe

commit ee7333ae06f46f3a6909a0059c2f0bd441a54bfe
Author: Doug Evans <xdje42@gmail.com>
Date:   Sat Jul 26 14:58:58 2014 -0700

    PR guile/17177
    
    	* guile/lib/gdb.scm (pretty-printers): Export.
    	(set-pretty-printers!): Export.
    	* guile/lib/gdb/printing.scm (gdb module): Update.
    	(prepend-pretty-printer!, append-pretty-printer!): Update.
    	* guile/scm-pretty-print.c (pretty_printer_list_name): Delete.
    	(pretty_printer_list_var): Delete.
    	(pretty_printer_list): New static global.
    	(gdbscm_pretty_printers): New function.
    	(gdbscm_set_pretty_printers_x): New function.
    	(ppscm_find_pretty_printer_from_gdb): Update.
    	(pretty_printer_functions): Add pretty-printers, set-pretty-printers!.
    	(gdbscm_initialize_pretty_printers): Update.
    
    	doc/
    	* guile.texi (Guile Pretty Printing API): Fix typo.
    	Document set-pretty-printers!, pretty-printers.
    	(Selecting Guile Pretty-Printers): Update.
    	Mention program-space based pretty-printers.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog                  |   16 ++++++++++++
 gdb/doc/ChangeLog              |    8 ++++++
 gdb/doc/guile.texi             |   40 ++++++++++++++++++++++--------
 gdb/guile/lib/gdb.scm          |    2 +
 gdb/guile/lib/gdb/printing.scm |    7 +++--
 gdb/guile/scm-pretty-print.c   |   51 ++++++++++++++++++++++++++++-----------
 6 files changed, 95 insertions(+), 29 deletions(-)
Comment 2 cvs-commit@gcc.gnu.org 2014-07-27 03:41:32 UTC
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, gdb-7.8-branch has been updated
       via  68455456ca7b1f35ce97f62c50b466e2fc9cce8f (commit)
      from  b13f24b87c227ef532cac27fc81f85b60fba2832 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=68455456ca7b1f35ce97f62c50b466e2fc9cce8f

commit 68455456ca7b1f35ce97f62c50b466e2fc9cce8f
Author: Doug Evans <xdje42@gmail.com>
Date:   Sat Jul 26 20:39:33 2014 -0700

    PR guile/17177
    
    	* guile/lib/gdb.scm (pretty-printers): Export.
    	(set-pretty-printers!): Export.
    	* guile/lib/gdb/printing.scm (gdb module): Update.
    	(prepend-pretty-printer!, append-pretty-printer!): Update.
    	* guile/scm-pretty-print.c (pretty_printer_list_name): Delete.
    	(pretty_printer_list_var): Delete.
    	(pretty_printer_list): New static global.
    	(gdbscm_pretty_printers): New function.
    	(gdbscm_set_pretty_printers_x): New function.
    	(ppscm_find_pretty_printer_from_gdb): Update.
    	(pretty_printer_functions): Add pretty-printers, set-pretty-printers!.
    	(gdbscm_initialize_pretty_printers): Update.
    
    	doc/
    	* guile.texi (Guile Pretty Printing API): Fix typo.
    	Document set-pretty-printers!, pretty-printers.
    	(Selecting Guile Pretty-Printers): Update.
    	Mention program-space based pretty-printers.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog                  |   16 ++++++++++++
 gdb/doc/ChangeLog              |    8 ++++++
 gdb/doc/guile.texi             |   40 ++++++++++++++++++++++--------
 gdb/guile/lib/gdb.scm          |    2 +
 gdb/guile/lib/gdb/printing.scm |    7 +++--
 gdb/guile/scm-pretty-print.c   |   51 ++++++++++++++++++++++++++++-----------
 6 files changed, 95 insertions(+), 29 deletions(-)
Comment 3 Doug Evans 2014-07-28 01:07:47 UTC
patch applied