Bug 15460 - lack of "relocation truncated to fit: R_X86_64_32 against `.debug_info'" failure for too large debug info
Summary: lack of "relocation truncated to fit: R_X86_64_32 against `.debug_info'" fail...
Status: RESOLVED DUPLICATE of bug 18695
Alias: None
Product: binutils
Classification: Unclassified
Component: gold (show other bugs)
Version: 2.24
: P2 normal
Target Milestone: ---
Assignee: Ian Lance Taylor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-11 01:34 IST by Peeter Joot
Modified: 2016-03-27 20:33 IST (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peeter Joot 2013-05-11 01:34:09 IST
As noted in:

http://sourceware.org/bugzilla/show_bug.cgi?id=15444#c14

the gold linker should also fail when the size of the debug info exceeds the 32-bit limits.  Example: with 6Gb of debug data, ld.bfd produces the diagnostic:

 relocation truncated to fit: R_X86_64_32 against `.debug_info'

and then fails.
Comment 1 Cary Coutant 2016-03-27 20:33:52 IST
Resolving as duplicate. PR 18695 is more comprehensive and contains more discussion.

*** This bug has been marked as a duplicate of bug 18695 ***