Bug 1497 - NullPointerException when using stackDown button
Summary: NullPointerException when using stackDown button
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P1 normal
Target Milestone: ---
Assignee: Adam Jocksch
URL:
Keywords:
Depends on:
Blocks: 1633 1838
  Show dependency treegraph
 
Reported: 2005-10-18 19:24 UTC by Adam Jocksch
Modified: 2006-10-27 17:23 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
test case that breaks with gij/gcj (306 bytes, text/plain)
2005-10-20 14:01 UTC, Adam Jocksch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Jocksch 2005-10-18 19:24:48 UTC
The title says it all. This is believed to be associated with a TreeIter problem
in Java-gnome
Comment 1 Adam Jocksch 2005-10-18 20:49:32 UTC
The problem has been found in java-gnome, and hopefully a patch will be applied soon
Comment 2 Adam Jocksch 2005-10-18 21:23:30 UTC
A workaround has been implemented that works on gcj. However upon further
inspection the bug appears to be a gcj/gij problem.
Comment 3 Adam Jocksch 2005-10-20 14:01:39 UTC
Created attachment 722 [details]
test case that breaks with gij/gcj

When this is run with gij or compiled natively with gcj it generates a
NullPointerException (in the case of gcj) or an IllegalClassChangeException (in
the case of gij)
Comment 4 Adam Jocksch 2005-10-20 14:02:09 UTC
Test case submitted for gij/gcj breakage, will be converted into a build test
Comment 5 Adam Jocksch 2006-03-09 18:12:57 UTC
I am marking this bug closed, since the weak reference bug in gcj that was
causing this has been included in gcc 4.1.