Bug 14823 - GDBserver: debugging multiple processes of mixed architectures
Summary: GDBserver: debugging multiple processes of mixed architectures
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: server (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: 7.7
Assignee: Pedro Alves
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-09 14:37 UTC by Pedro Alves
Modified: 2013-06-07 10:59 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Alves 2012-11-09 14:37:39 UTC
Although GDBserver supports biarch, when debugging multiple processes, they must all be of the same arch, due to implementation limitations.  This limitation should be lifted.
Comment 1 Pedro Alves 2012-11-09 14:39:03 UTC
Latest patch series fixing this posted at <http://sourceware.org/ml/gdb-patches/2012-04/msg00202.html>.

Patch 1 has meanwhile been applied to mainline: http://sourceware.org/ml/gdb-patches/2012-11/msg00228.html
Comment 2 cvs-commit@gcc.gnu.org 2013-06-07 10:55:24 UTC
CVSROOT:	/cvs/src
Module name:	src
Changes by:	palves@sourceware.org	2013-06-07 10:55:22

Modified files:
	gdb            : ChangeLog 
	gdb/gdbserver  : ChangeLog 

Log message:
	Mention PR server/14823 in ChangeLogs.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/ChangeLog.diff?cvsroot=src&r1=1.15696&r2=1.15697
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/gdbserver/ChangeLog.diff?cvsroot=src&r1=1.723&r2=1.724
Comment 3 Pedro Alves 2013-06-07 10:59:06 UTC
GDBserver side applied too:
 http://sourceware.org/ml/gdb-patches/2013-06/msg00140.html