Bug 1394 - procfs.h on ppc32 fails due to __uint128_t
Summary: procfs.h on ppc32 fails due to __uint128_t
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.5
: P1 critical
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks: libc236
  Show dependency treegraph
 
Reported: 2005-09-30 02:27 UTC by Brian Strelioff
Modified: 2005-10-17 05:02 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Strelioff 2005-09-30 02:27:54 UTC
Lines 57/58 in procfs.h cause a compilation error for the ppc32 platform.
Comment 1 Ulrich Drepper 2005-10-15 19:45:29 UTC

*** This bug has been marked as a duplicate of 333 ***
Comment 2 Roland McGrath 2005-10-16 09:33:43 UTC
This is a legitimate bug, if poorly explained in the report.
The problematic code is in an installed user header, so it's not just a glibc
build issue.  There is a trunk fix already, will backport to 2.3.
Comment 3 cvs-commit@gcc.gnu.org 2005-10-16 09:34:11 UTC
Subject: Bug 1394

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-16 09:34:03

Modified files:
	sysdeps/unix/sysv/linux/powerpc/sys: procfs.h 

Log message:
	2005-02-21  Alan Modra <amodra@bigpond.net.au>
	
	[BZ #1394]
	* sysdeps/unix/sysv/linux/powerpc/sys/procfs.h (elf_vrreg_t): Don't
	use __uint128_t.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/unix/sysv/linux/powerpc/sys/procfs.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.11&r2=1.11.4.1

Comment 4 Roland McGrath 2005-10-17 05:02:01 UTC
These changes are now in both the trunk and the 2.3 branch.