Bug 1387 - .equiv may not detect already defined symbol
Summary: .equiv may not detect already defined symbol
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: gas (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-28 15:23 UTC by Jan Beulich
Modified: 2006-03-17 08:26 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build: *-*-*
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beulich 2005-09-28 15:23:00 UTC
For example, in

 .equiv	x, y
 .equiv	x, 1

the re-definition is not detected, because x gets associated (in pseudo_set)
with undefined_section during the first assignment.
Comment 1 Jan Beulich 2005-09-29 08:29:08 UTC
See also http://sourceware.org/ml/binutils/2005-09/msg00280.html and its follow-ups.
Comment 2 Jan Beulich 2006-03-17 08:26:37 UTC
This should be resolved with a checkin from 2005-10-27.