Bug 1369 - Create yum repository for 3rd party RPMs
Summary: Create yum repository for 3rd party RPMs
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P1 normal
Target Milestone: ---
Assignee: Igor Foox
URL:
Keywords:
Depends on:
Blocks: 1975
  Show dependency treegraph
 
Reported: 2005-09-23 14:46 UTC by Anthony Green
Modified: 2012-07-23 19:19 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Repo file for the frysk repository (97 bytes, text/plain)
2005-09-27 16:53 UTC, Igor Foox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Green 2005-09-23 14:46:50 UTC
The build instructions contain links to RPMs for frysk's dependencies.  Could
you please reorganize these into a yum repository?  That would make them much
easier to deal with.

I'd be happy to help with this in you need it.

Thanks!

AG
Comment 1 Igor Foox 2005-09-23 17:57:19 UTC
Good suggestion. I have no idea how to do this right now, so I will defer it a
bit. But I'll  hold you to the promise to help sometime next week. :)

Igor
Comment 2 Igor Foox 2005-09-27 16:53:57 UTC
Created attachment 673 [details]
Repo file for the frysk repository

I created a repository. Putting the attached frysk.repo in your
/etc/yum.repos.d/ directory should add the repo.

Anthony, I can't run createrepo on the sourceware machine because it's not
installed there, so I have to run it on my machine and upload things, is there
any way I can sync it more easily than just scping files?

Igor
Comment 3 Anthony Green 2005-09-27 19:19:46 UTC
(In reply to comment #2) 
> Anthony, I can't run createrepo on the sourceware machine because it's not
> installed there, so I have to run it on my machine and upload things, is there
> any way I can sync it more easily than just scping files?

Use rsync.

$ export RSYNC_RSH=ssh
$ rsync -av SRCDIR sources.redhat.com:/TARGETDIR

AG
Comment 4 Igor Foox 2005-09-30 18:35:10 UTC
Repo was created.