Bug 13428 - nfsd.stp failure on f16 because of renamed kernel function
Summary: nfsd.stp failure on f16 because of renamed kernel function
Status: RESOLVED FIXED
Alias: None
Product: systemtap
Classification: Unclassified
Component: tapsets (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-22 15:07 UTC by David Smith
Modified: 2011-11-22 15:10 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Smith 2011-11-22 15:07:59 UTC
On newer kernels (such as f16), the nfsd.createv3 and nfsd.createv3.return probes fail to resolve since the function they probe was renamed by the following kernel commit.  This caused the buildok/nfsd-all-probes.stp testcase to fail.

commit ac6721a13e5b1a90728e790600f827a5e5f5da2f
Author: Mi Jinlong <mijinlong@cn.fujitsu.com>
Date:   Wed Apr 20 17:06:25 2011 +0800

    nfsd41: make sure nfs server process OPEN with EXCLUSIVE4_1 correctly
    
    The NFS server uses nfsd_create_v3 to handle EXCLUSIVE4_1 opens, but
    that function is not prepared to handle them.
    
    Rename nfsd_create_v3() to do_nfsd_create(), and add handling of
    EXCLUSIVE4_1.
    
    Signed-off-by: Mi Jinlong <mijinlong@cn.fujitsu.com>
    Signed-off-by: J. Bruce Fields <bfields@redhat.com>
Comment 1 David Smith 2011-11-22 15:10:58 UTC
Fixed in commit 4efa8b2.