Bug 12941 - Ignore __extension__ in the parser
Summary: Ignore __extension__ in the parser
Status: RESOLVED DUPLICATE of bug 9748
Alias: None
Product: gdb
Classification: Unclassified
Component: exp (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: archer
Depends on:
Blocks:
 
Reported: 2011-06-27 17:09 IST by Jan Kratochvil
Modified: 2013-03-04 18:08 IST (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kratochvil 2011-06-27 17:09:26 IST
Actual:
(gdb) ptype ENUM_BITFIELD(address_class)
No symbol "__extension__" in current context.

Expected:
(gdb) ptype enum address_class
type = enum address_class {LOC_UNDEF, LOC_CONST, LOC_STATIC, LOC_REGISTER, LOC_ARG, LOC_REF_ARG, LOC_REGPARM_ADDR, LOC_LOCAL, LOC_TYPEDEF, LOC_LABEL, LOC_BLOCK, LOC_CONST_BYTES, LOC_UNRESOLVED, LOC_OPTIMIZED_OUT, LOC_COMPUTED}

This breaks usage of macros in -g3 builds.

(gdb) info macro ENUM_BITFIELD
[...]
#define ENUM_BITFIELD(TYPE) __extension__ enum TYPE


But for example ({...}) still cannot get be parsed.
Comment 1 Pedro Alves 2011-06-28 09:05:57 IST
See PR 9748.
Comment 2 Jan Kratochvil 2011-06-28 09:10:38 IST
Thanks, so it is a duplicate.

*** This bug has been marked as a duplicate of bug 9748 ***