Bug 12737 - arm-elf sim testsuite has "new" failures
Summary: arm-elf sim testsuite has "new" failures
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: sim (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-06 01:01 UTC by Hans-Peter Nilsson
Modified: 2011-07-01 14:56 UTC (History)
2 users (show)

See Also:
Host: x86_64-unknown-linux-gnu
Target: arm-elf
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Nilsson 2011-05-06 01:01:45 UTC
A recent change has enabled portions of the sim testsuite that were previously effectively disabled (from being gated on [istarget xscale*-*-*] which never matched, to now being gated on [istarget arm*-*-*]).  Four of these new tests fail thus, configured for arm-elf and using the arm-sim board:

Running /tmp/hpautotest-sim/src/sim/testsuite/sim/arm/iwmmxt/iwmmxt.exp ...
FAIL: xscale wcmpgt.cgs (execution)
FAIL: xscale wmac.cgs (execution)
FAIL: xscale wsra.cgs (execution)
Running /tmp/hpautotest-sim/src/sim/testsuite/sim/arm/misc.exp ...
Running /tmp/hpautotest-sim/src/sim/testsuite/sim/arm/thumb/allthumb.exp ...
Running /tmp/hpautotest-sim/src/sim/testsuite/sim/arm/xscale/xscale.exp ...
WARNING: program timed out.
FAIL: xscale blx.cgs (execution)

Original contributor of these tests CC:ed.
Comment 2 Hans-Peter Nilsson 2011-07-01 04:15:55 UTC
Looks like the actual cause was the same as PR gas/12931, because after an update to an assembler including that fix, the test has started kpassing.  I'd like verification from an ARM person before removing the kpass and closing, though.
Comment 3 cvs-commit@gcc.gnu.org 2011-07-01 12:12:26 UTC
CVSROOT:	/cvs/src
Module name:	src
Changes by:	nickc@sourceware.org	2011-07-01 12:12:17

Modified files:
	sim/arm        : ChangeLog iwmmxt.c 

Log message:
	PR sim/12737
	* iwmmxt.c (WCMPGT): Sign extend 32-bit values before performing a
	signed compare.
	(WMAC): Extend computed result before adding to result register.
	(WRSA): Sign extend 32-bit values before shifting.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/arm/ChangeLog.diff?cvsroot=src&r1=1.108&r2=1.109
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/arm/iwmmxt.c.diff?cvsroot=src&r1=1.10&r2=1.11
Comment 4 cvs-commit@gcc.gnu.org 2011-07-01 12:15:24 UTC
CVSROOT:	/cvs/src
Module name:	src
Changes by:	nickc@sourceware.org	2011-07-01 12:15:18

Modified files:
	sim/testsuite  : ChangeLog 
	sim/testsuite/sim/arm/xscale: blx.cgs 
	sim/testsuite/sim/arm/iwmmxt: wcmpgt.cgs wmac.cgs wsra.cgs 

Log message:
	PR sim/12737
	* sim/arm/iwmmxt/wcmpgt.cgs: Remove expectation of failure.
	* sim/arm/iwmmxt/wmac.cgs: Remove expectation of failure.
	* sim/arm/iwmmxt/wsra.cgs: Remove expectation of failure.
	* sim/arm/xscale/blx.cgs: Remove expectation of failure.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/testsuite/ChangeLog.diff?cvsroot=src&r1=1.69&r2=1.70
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/testsuite/sim/arm/xscale/blx.cgs.diff?cvsroot=src&r1=1.2&r2=1.3
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/testsuite/sim/arm/iwmmxt/wcmpgt.cgs.diff?cvsroot=src&r1=1.2&r2=1.3
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/testsuite/sim/arm/iwmmxt/wmac.cgs.diff?cvsroot=src&r1=1.2&r2=1.3
http://sourceware.org/cgi-bin/cvsweb.cgi/src/sim/testsuite/sim/arm/iwmmxt/wsra.cgs.diff?cvsroot=src&r1=1.2&r2=1.3
Comment 5 Nick Clifton 2011-07-01 12:16:41 UTC
Hi Hans-Peter,

  The xscale/blx.cgs test was fixed by PR12931 but the other three were not.  They were all due to bugs in the ARM simulator, now fixed.

Cheers
  Nick
Comment 6 Hans-Peter Nilsson 2011-07-01 14:56:25 UTC
(In reply to comment #5)
>   The xscale/blx.cgs test was fixed by PR12931 but the other three were not.

Right; that one kfailed, status unchanged for the others before your sim fix.

> They were all due to bugs in the ARM simulator, now fixed.

Thanks!