Bug 12690 - unsupported static user probe asm arg descriptors
Summary: unsupported static user probe asm arg descriptors
Status: RESOLVED DUPLICATE of bug 13296
Alias: None
Product: systemtap
Classification: Unclassified
Component: translator (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-20 20:21 IST by Stan Cox
Modified: 2011-12-01 02:50 IST (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
sdt arg asm descriptor (274 bytes, text/plain)
2011-04-20 20:52 IST, Stan Cox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stan Cox 2011-04-20 20:21:47 IST
This test generates asm args of the form: a(%eax,%edx,4) that are unsupported by the stap static probe asm arg parser
Comment 1 Stan Cox 2011-04-20 20:52:46 IST
Created attachment 5683 [details]
sdt arg asm descriptor
Comment 2 Sergio Durigan Junior 2011-12-01 02:43:25 IST
I believe this is a duplicate of #13313, right?
Comment 3 Frank Ch. Eigler 2011-12-01 02:50:24 IST
Sergio, mostly right; the part that's still missing from the
systemtap side is the resolution of symbols as base values.

*** This bug has been marked as a duplicate of bug 13296 ***