Bug 1266 - script tracing
Summary: script tracing
Status: RESOLVED WONTFIX
Alias: None
Product: systemtap
Classification: Unclassified
Component: translator (show other bugs)
Version: unspecified
: P3 enhancement
Target Milestone: week
Assignee: Unassigned
URL:
Keywords:
: 1267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-29 21:33 UTC by Frank Ch. Eigler
Modified: 2007-10-02 21:05 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Ch. Eigler 2005-08-29 21:33:17 UTC
It might be nice to have a translator option that inserts tracing calls into the
C code, so a programmer wishing to debug his systemtap script can watch it work
statement by statement.  A naive form could generate a flood of tracing traffic.
 A smarter form may pass tokens identifying the statement/subexpression in a
compact way, relying on stpd to decode it.  Think "branch history buffer".
Comment 1 Frank Ch. Eigler 2005-08-29 21:33:52 UTC
*** Bug 1267 has been marked as a duplicate of this bug. ***
Comment 2 Frank Ch. Eigler 2005-09-06 16:14:51 UTC
See the way that c->last_stmt is set throughout translated code.
A sibling array could accumulate codes that stand for those same points.
Comment 3 Frank Ch. Eigler 2007-10-02 21:05:11 UTC
This doesn't sound like such a good idea any more.