Bug 12589 - Assertion failure in get_known_segmented_expression
Summary: Assertion failure in get_known_segmented_expression
Status: RESOLVED DUPLICATE of bug 12569
Alias: None
Product: binutils
Classification: Unclassified
Component: gas (show other bugs)
Version: 2.22
: P2 normal
Target Milestone: ---
Assignee: unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-16 21:20 UTC by H.J. Lu
Modified: 2011-03-17 13:16 UTC (History)
1 user (show)

See Also:
Host:
Target: i386-linux
Build:
Last reconfirmed:


Attachments
A testcase (1.12 KB, application/octet-stream)
2011-03-16 21:21 UTC, H.J. Lu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2011-03-16 21:20:54 UTC
[hjl@gnu-6 20110316]$ ./usr/local/bin/as --32  -o handoff.o handoff.s
handoff.S: Assembler messages:
handoff.S:344: Internal error!
Assertion failure in get_known_segmented_expression at /net/gnu-6/export/linux/src/binutils/binutils/gas/read.c line 5434.
Please report this bug.
[hjl@gnu-6 20110316]$
Comment 1 H.J. Lu 2011-03-16 21:21:19 UTC
Created attachment 5314 [details]
A testcase
Comment 2 H.J. Lu 2011-03-16 21:29:59 UTC
It is caused by

http://sourceware.org/ml/binutils/2010-09/msg00498.html
Comment 3 H.J. Lu 2011-03-16 21:45:31 UTC
A simpler testcase:

[hjl@gnu-6 20110316]$ cat x.S
 .text
 .globl _start
_start:
 jmp scn_pnp
zerob:
zeroln = (420 - (zerob - _start))
 .=.+zeroln
[hjl@gnu-6 20110316]$ as -o x.o x.S
x.S: Assembler messages:
x.S:7: Internal error!
Assertion failure in get_known_segmented_expression at /net/gnu-6/export/linux/src/binutils/binutils/gas/read.c line 5435.
Please report this bug.
[hjl@gnu-6 20110316]$
Comment 4 Alan Modra 2011-03-17 09:22:21 UTC
.

*** This bug has been marked as a duplicate of bug 12569 ***
Comment 5 cvs-commit@gcc.gnu.org 2011-03-17 13:16:48 UTC
CVSROOT:	/cvs/src
Module name:	src
Changes by:	hjl@sourceware.org	2011-03-17 13:16:44

Modified files:
	gas/testsuite  : ChangeLog 
	gas/testsuite/gas/i386: i386.exp 
Added files:
	gas/testsuite/gas/i386: pr12589-1.d pr12589-1.s 

Log message:
	Add a testase for PR gas/12589.
	
	2011-03-17  H.J. Lu  <hongjiu.lu@intel.com>
	
	PR gas/12589
	* gas/i386/pr12589-1.d: New.
	* gas/i386/pr12589-1.s: Likewise.
	
	* gas/i386/i386.exp: Run pr12589-1.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/testsuite/ChangeLog.diff?cvsroot=src&r1=1.1865&r2=1.1866
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/testsuite/gas/i386/pr12589-1.d.diff?cvsroot=src&r1=NONE&r2=1.1
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/testsuite/gas/i386/pr12589-1.s.diff?cvsroot=src&r1=NONE&r2=1.1
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/testsuite/gas/i386/i386.exp.diff?cvsroot=src&r1=1.158&r2=1.159