Bug 12569 - Assertion failure in get_known_segmented_expression (ARM)
Summary: Assertion failure in get_known_segmented_expression (ARM)
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: gas (show other bugs)
Version: 2.22
: P2 normal
Target Milestone: ---
Assignee: Alan Modra
URL:
Keywords:
: 12589 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-11 08:48 UTC by pdox
Modified: 2011-03-17 11:25 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pdox 2011-03-11 08:48:57 UTC
demo.s:

.p2align 4
pcpos:

.globl foo
.type foo,function
.p2align 4

bx lr

.set pos, (. - pcpos)
.fill (pos & 15), 4, 0x0



$ install/arm-none-linux-gnueabi/bin/as  demo.s

demo.s: Assembler messages:
demo.s:11: Internal error!
Assertion failure in get_known_segmented_expression at ../../src/gas/read.c line 5435.
Please report this bug.
Comment 1 Alan Modra 2011-03-17 09:22:21 UTC
*** Bug 12589 has been marked as a duplicate of this bug. ***
Comment 2 cvs-commit@gcc.gnu.org 2011-03-17 10:59:34 UTC
CVSROOT:	/cvs/src
Module name:	src
Changes by:	amodra@sourceware.org	2011-03-17 10:59:30

Modified files:
	gas            : ChangeLog expr.c read.c 

Log message:
	PR 12569
	* expr.c (operand): Correct passing of "mode" to expr.
	* read.c (do_org): Allow expr_section.
	(get_known_segmented_expression): Don't assert anything about the
	segment.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/ChangeLog.diff?cvsroot=src&r1=1.4432&r2=1.4433
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/expr.c.diff?cvsroot=src&r1=1.89&r2=1.90
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/read.c.diff?cvsroot=src&r1=1.169&r2=1.170
Comment 3 cvs-commit@gcc.gnu.org 2011-03-17 11:00:49 UTC
CVSROOT:	/cvs/src
Module name:	src
Branch: 	binutils-2_21-branch
Changes by:	amodra@sourceware.org	2011-03-17 11:00:47

Modified files:
	gas            : ChangeLog expr.c read.c 

Log message:
	PR 12569
	* expr.c (operand): Correct passing of "mode" to expr.
	* read.c (do_org): Allow expr_section.
	(get_known_segmented_expression): Don't assert anything about the
	segment.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/ChangeLog.diff?cvsroot=src&only_with_tag=binutils-2_21-branch&r1=1.4320.2.19&r2=1.4320.2.20
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/expr.c.diff?cvsroot=src&only_with_tag=binutils-2_21-branch&r1=1.85.2.1&r2=1.85.2.2
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gas/read.c.diff?cvsroot=src&only_with_tag=binutils-2_21-branch&r1=1.167.2.1&r2=1.167.2.2
Comment 4 Alan Modra 2011-03-17 11:25:29 UTC
Fixed