Bug 12431 - `gold -r' strips LTO sections
Summary: `gold -r' strips LTO sections
Status: RESOLVED WORKSFORME
Alias: None
Product: binutils
Classification: Unclassified
Component: gold (show other bugs)
Version: 2.22
: P2 normal
Target Milestone: ---
Assignee: Ian Lance Taylor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-22 01:45 UTC by Dmitry Gorbachev
Modified: 2013-02-13 12:00 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Object file with .gnu.lto_.* sections (570 bytes, application/octet-stream)
2011-07-15 12:34 UTC, Dmitry Gorbachev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Gorbachev 2011-01-22 01:45:17 UTC
$ touch 1.c
$ gcc -c -flto 1.c
$ objdump -h 1.o | grep -c lto
7
$ ld.gold -r 1.o
$ objdump -h a.out | grep -c lto
0
Comment 1 Ian Lance Taylor 2011-07-09 05:39:29 UTC
This test works for me with current gold sources.  Please reopen this bug report if it continues to fail for you.
Comment 2 Dmitry Gorbachev 2011-07-14 19:13:42 UTC
Still happens with current GOLD (i686-pc-linux-gnu).
Comment 3 Ian Lance Taylor 2011-07-15 05:04:09 UTC
I can not recreate this.  Please attach the object file 1.o which shows this problem.
Comment 4 Dmitry Gorbachev 2011-07-15 12:34:43 UTC
Created attachment 5851 [details]
Object file with .gnu.lto_.* sections
Comment 5 Dmitry Gorbachev 2013-02-13 12:00:47 UTC
I can't reproduce it with recent ld.gold.