Bug 11847 - sdt.h for ppc, -mno-regnames, use %I0%0
Summary: sdt.h for ppc, -mno-regnames, use %I0%0
Status: RESOLVED DUPLICATE of bug 11916
Alias: None
Product: systemtap
Classification: Unclassified
Component: translator (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-28 21:57 IST by Frank Ch. Eigler
Modified: 2010-09-01 14:56 IST (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Ch. Eigler 2010-07-28 21:57:22 IST
We sort of gave up back in bug #11821, but it turns out we can
do somewhat better, if the "%0" is replaced with "%I0%0" for
each SDT_V2 operand slot, for powerpc only.  This would cause
literals to be prefixed with "i", resolving the ambiguity.

Then in turn the translator's $nnnn regex matcher (tapsets.cxx:4675ish)
could accept "i" as a literal number prefix, not just "$".

Up to this point, it's all compatible with SDT_V2 binaries & logic.

However, the later REGISTER case can't presume that the lack-of-"i"
means a register number, since SDT_V2 binaries may exist that precede
this particular change.  So a later magic number may need to be assigned
to communicate to the translator that %I0%0 was specified, and thus
lack-of-"i" means "register number, for sure".
Comment 1 Frank Ch. Eigler 2010-09-01 14:56:51 IST
Part of sdt v3.

*** This bug has been marked as a duplicate of 11916 ***