Bug 11301 - input freezes in XDMCP session
Summary: input freezes in XDMCP session
Status: RESOLVED FIXED
Alias: None
Product: cygwin
Classification: Unclassified
Component: Cygwin/X (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Yaakov Selkowitz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-19 17:02 UTC by Jon Turney
Modified: 2010-10-05 00:10 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Turney 2010-02-19 17:02:17 UTC
http://sourceware.org/ml/cygwin-xfree/2010-02/msg00023.html

Easily reproduced following steps in that email.

I'm pretty sure this was working with Xserver 1.6.x, and reporter agrees, but
it's not immediately obvious what's changed to break it.
Comment 1 Jon Turney 2010-02-19 17:14:55 UTC
http://sourceware.org/ml/cygwin-xfree/2010-01/msg00114.html looks like the same
issue, so possibly occurs with other remote host OS as well.

(nothing happening with numlock is
http://x.cygwin.com/docs/faq/cygwin-x-faq.html#numlock-modifier)
Comment 2 Jon Turney 2010-02-19 18:23:54 UTC
and this http://sourceware.org/ml/cygwin-xfree/2010-01/msg00048.html
Comment 3 Jon Turney 2010-02-19 22:32:33 UTC
and again... http://cygwin.com/ml/cygwin/2010-02/msg00523.html
Comment 4 Jon Turney 2010-02-21 15:01:04 UTC
After rather too long spent debugging and discovering this is due to the input
device getting frozen but not thawed when a passive grab triggers, it occured to
me to check if this problem is also shown in the XOrg DDX.

Reproduced with FC12 Xserver 1.7.1-7. Updating to Xserver 1.7.4-6, the problem
goes away....
Comment 6 Jon Turney 2010-02-21 16:01:43 UTC
confirming that the patch in fd.o bug #25400 fixes this.
Comment 7 Yaakov Selkowitz 2010-02-21 18:02:29 UTC
Thanks for tracking this down.  Patch from fd.o 25400 pulled and cherry-picked 
into 1.7 branch.  Closing.
Comment 8 Jon Turney 2010-03-02 16:25:22 UTC
Reopening, this patch only seems to have resovled some of the problems

http://cygwin.com/ml/cygwin-xfree/2010-02/msg00177.html
Comment 9 Jon Turney 2010-03-02 16:32:55 UTC
Follwing the steps in Marks' email, the reproduction I have is:

X -query solaris10vm
start CDE session
click on one of the "^" on the panel to launch something
note that you can interact with that application, reize etc.
go back to click on the panel
input is now frozen

Reproduced with Xwin 1.7.5-1, XWin 1.7.5-1 with the latest patch for fd.o
bugzilla #25400 applied [1], and FC12 xorg-x11-xserver-Xorg-1.7.5-1

[1] http://lists.x.org/archives/xorg-devel/2010-February/005845.html
Comment 10 Jon Turney 2010-03-09 01:28:52 UTC
and again http://cygwin.com/ml/cygwin-xfree/2010-03/msg00022.html

Solaris 2.5.1, Initial Release: May 1996, woohoo!
Comment 12 Jon Turney 2010-08-03 20:00:50 UTC
and again http://cygwin.com/ml/cygwin-xfree/2010-08/msg00000.html
Comment 13 Jon Turney 2010-08-03 20:05:52 UTC
There have been some relevant changes in X server 1.9, and from some brief
testing with the 1.8.99.905 (1.9 RC 5), it looks like this is resolved in 1.9
Comment 14 Yaakov Selkowitz 2010-10-04 20:16:21 UTC
(In reply to comment #13)
> There have been some relevant changes in X server 1.9, and from some brief
> testing with the 1.8.99.905 (1.9 RC 5), it looks like this is resolved in 1.9

Has this been confirmed?
Comment 15 Jon Turney 2010-10-04 23:53:26 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > There have been some relevant changes in X server 1.9, and from some brief
> > testing with the 1.8.99.905 (1.9 RC 5), it looks like this is resolved in 1.9
> 
> Has this been confirmed?

The reproduction steps in comment #9 no longer reproduce the problem with Xserver 1.9.0-1, so I guess this is confirmed as fixed :-)