Bug 1119 - add some translation warnings
Summary: add some translation warnings
Status: RESOLVED FIXED
Alias: None
Product: systemtap
Classification: Unclassified
Component: translator (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: days
Assignee: Unassigned
URL:
Keywords:
: 5111 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-21 15:06 UTC by Frank Ch. Eigler
Modified: 2007-10-06 02:42 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Ch. Eigler 2005-07-21 15:06:35 UTC
- detect cases of read-only or written-only variables, since these may be typos
Comment 1 Frank Ch. Eigler 2007-10-05 00:18:22 UTC
*** Bug 5111 has been marked as a duplicate of this bug. ***
Comment 2 Josh Stone 2007-10-05 17:09:16 UTC
Written-only variables are questionable, because many of the tapset variables
are optimized out in this way.  But I agree that read-only variables will almost
always be typos.
Comment 3 Frank Ch. Eigler 2007-10-06 02:42:39 UTC
patch committed, enjoy!