Bug 11171 - RTTI symbol not found for class
Summary: RTTI symbol not found for class
Status: RESOLVED DUPLICATE of bug 14235
Alias: None
Product: gdb
Classification: Unclassified
Component: c++ (show other bugs)
Version: unknown
: P2 normal
Target Milestone: 7.1
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-14 18:21 UTC by Daniel Colascione
Modified: 2014-05-28 19:44 UTC (History)
4 users (show)

See Also:
Host: x86_64-apple-darwin10.2.0
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Colascione 2010-01-14 18:21:07 UTC
gdb prints this when I try to print values from an object of a class:

warning: RTTI symbol not found for class
'mpc::dbg::bidirectional_iterator_wrapper<boost::intrusive::list_iterator<boost::intrusive::list_impl<boost::intrusive::listopt<boost::intrusive::detail::member_hook_traits<mpc::dbg::tracked_base,
boost::intrusive::list_member_hook<boost::intrusive::link_mode<(boost::intrusive::link_mode_type)2>,
boost::intrusive::none, boost::intrusive::none>,
&(mpc::dbg::tracked_base::hook)>, unsigned long, false> >, false> >'

I have no such type in my program according to info types, but I do have a very
similar types:

File ../revproxy/debug.hpp:
mpc::dbg::bidirectional_iterator_wrapper<boost::intrusive::list_iterator<boost::intrusive::list_impl<boost::intrusive::listopt<boost::intrusive::detail::member_hook_traits<mpc::dbg::tracked_base,
boost::intrusive::list_member_hook<boost::intrusive::link_mode<auto_unlink>,
boost::intrusive::none, boost::intrusive::none>,
&(mpc::dbg::tracked_base::hook)>, unsigned long, false> >, false> >;
mpc::dbg::bidirectional_iterator_wrapper<boost::intrusive::list_iterator<boost::intrusive::list_impl<boost::intrusive::listopt<boost::intrusive::detail::member_hook_traits<mpc::dbg::tracked_base,
boost::intrusive::list_member_hook<boost::intrusive::link_mode<auto_unlink>,
boost::intrusive::none, boost::intrusive::none>,
&(mpc::dbg::tracked_base::hook)>, unsigned long, false> >, true> >;

File ../revproxy/debug.cpp:
typedef
mpc::dbg::bidirectional_iterator_wrapper<boost::intrusive::list_iterator<boost::intrusive::list_impl<boost::intrusive::listopt<boost::intrusive::detail::member_hook_traits<mpc::dbg::tracked_base,
boost::intrusive::list_member_hook<boost::intrusive::link_mode<auto_unlink>,
boost::intrusive::none, boost::intrusive::none>,
&(mpc::dbg::tracked_base::hook)>, unsigned long, false> >, false> >;
typedef
mpc::dbg::bidirectional_iterator_wrapper<boost::intrusive::list_iterator<boost::intrusive::list_impl<boost::intrusive::listopt<boost::intrusive::detail::member_hook_traits<mpc::dbg::tracked_base,
boost::intrusive::list_member_hook<boost::intrusive::link_mode<auto_unlink>,
boost::intrusive::none, boost::intrusive::none>,
&(mpc::dbg::tracked_base::hook)>, unsigned long, false> >, true> >;

(Yes, these names are insane.)
Comment 1 Tom Tromey 2011-11-02 14:39:21 UTC
Is there any way to get a reproducer for this?
Preferably a smallish program :)
Comment 2 Jan Kratochvil 2013-01-30 09:28:18 UTC
No more feedback here and it looks exactly like the better reproducibility looking PR 14235.

*** This bug has been marked as a duplicate of bug 14235 ***
Comment 3 Jackie Rosen 2014-02-16 18:27:48 UTC Comment hidden (spam)