Bug 10954 - unable to make glibc
Summary: unable to make glibc
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-13 16:57 UTC by abhishek
Modified: 2014-07-01 05:25 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:
fweimer: security-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abhishek 2009-11-13 16:57:30 UTC
root@abhi-lapi:/project/sources/Linux-Packages/glibc-build# make
make -r PARALLELMFLAGS="" CVSOPTS="" -C ../glibc-2.5.1 objdir=`pwd` all
make[1]: Entering directory `/project/sources/Linux-Packages/glibc-2.5.1'
mawk -f scripts/gen-sorted.awk \
	       -v subdirs='csu assert ctype locale intl catgets math setjmp signal
stdlib stdio-common libio malloc string wcsmbs time dirent grp pwd posix io
termios resource misc socket sysvipc gmon gnulib iconv iconvdata wctype manual
shadow po argp crypt nss localedata timezone rt conform debug  dlfcn elf' \
	       -v srcpfx='' \
	       nptl/sysdeps/pthread/Subdirs sysdeps/unix/inet/Subdirs
sysdeps/unix/Subdirs assert/Depend intl/Depend catgets/Depend stdlib/Depend
stdio-common/Depend libio/Depend malloc/Depend string/Depend wcsmbs/Depend
time/Depend posix/Depend iconvdata/Depend nss/Depend localedata/Depend rt/Depend
debug/Depend > /project/sources/Linux-Packages/glibc-build/sysd-sorted-tmp
mawk: scripts/gen-sorted.awk: line 19: regular expression compile failed (bad
class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /, "", subd ...
make[1]: *** No rule to make target
`/project/sources/Linux-Packages/glibc-build/Versions.all', needed by
`/project/sources/Linux-Packages/glibc-build/abi-versions.h'.  Stop.
make[1]: Leaving directory `/project/sources/Linux-Packages/glibc-2.5.1'
make: *** [all] Error 2
Comment 1 Ulrich Drepper 2009-11-13 17:11:32 UTC

*** This bug has been marked as a duplicate of 333 ***
Comment 2 Petr Baudis 2009-11-13 18:16:00 UTC
(It appears you are using mawk as the awk; gawk is required.)