Bug 1071 - glibc 2.3.5+CVS 2005/07/15 doesn't compile for ARM EABI targets
Summary: glibc 2.3.5+CVS 2005/07/15 doesn't compile for ARM EABI targets
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.5
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-15 18:27 UTC by Bernhard Rosenkraenzer
Modified: 2005-11-08 04:12 UTC (History)
2 users (show)

See Also:
Host: arm-linuxeabi
Target: arm-linuxeabi
Build: i686-ark-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2005-07-15 18:27:19 UTC
arm-linuxeabi-gcc -march=armv5te -mtune=xscale   -nostdlib -nostartfiles -r  
-o /usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/librtld.map.o  
'-Wl,-(' /usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/dl-allobjs.os /stuff/oe/tmp/work/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/libc_pic.a  
-lgcc '-Wl,-)'  
-Wl,-Map,/usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/librtld.mapT  
/usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/libc_pic.a(init-first.os): 
(.data+0x0): multiple definition of `__libc_multiple_libcs'  
/usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/dl-allobjs.os: 
(.bss+0x94): first defined here  
/usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/libc_pic.a(_itoa.os):  
In function `_itoa':  
_itoa.c:(.text+0x118): multiple definition of `_itoa'  
/usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/dl-allobjs.os:dl-sbrk.c: 
(.text+0x10f20): first defined here  
/usr/lib/gcc/arm-linuxeabi/3.4.4/../../../../arm-linuxeabi/bin/ld:  
Warning: size of symbol `_itoa' changed from 176  
in /usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/dl-allobjs.os  
to 1176  
in /usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/libc_pic.a(_itoa.os)  
collect2: ld returned 1 exit status  
make[2]: ***  
[/usr/src/glibc-2.3.5+cvs20050715-r0/build-arm-linuxeabi/elf/librtld.map]  
Error 1
Comment 1 Ulrich Drepper 2005-09-27 15:27:38 UTC

*** This bug has been marked as a duplicate of 333 ***
Comment 2 Bernhard Rosenkraenzer 2005-11-06 21:34:07 UTC
This is NOT a dup of 333, it was a genuine problem with the EABI toolchain. 
Anyway it's fixed these days. 
Comment 3 Khem Raj 2005-11-08 04:12:38 UTC
(In reply to comment #2)
> This is NOT a dup of 333, it was a genuine problem with the EABI toolchain. 
> Anyway it's fixed these days. 

I tried it with latest binutils spanshot from head and I still see the problem.
I am using gcc from 3.4 branch. It seems the problem is not fixed yet.