Bug 1045 - --disable-shared --enable-static-nss build failure
Summary: --disable-shared --enable-static-nss build failure
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.5
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on: 519 631 1043 1044 1050
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-03 10:41 UTC by Jan Kratochvil
Modified: 2005-07-19 03:44 UTC (History)
1 user (show)

See Also:
Host: i386-redhat-linux-gnu
Target: i386-redhat-linux-gnu
Build: i386-redhat-linux-gnu
Last reconfirmed:


Attachments
FC4 glibc-2.3.5-10 .spec patch for clear reproducibility (2.03 KB, patch)
2005-07-03 10:48 UTC, Jan Kratochvil
Details | Diff
Remove dependency on libgcc_s.so which is impossible for: --disable-shared (252 bytes, patch)
2005-07-03 10:49 UTC, Jan Kratochvil
Details | Diff
Fixes undefined linking crash for "--disable-shared". It may be a valid patch, not sure. (454 bytes, patch)
2005-07-03 10:51 UTC, Jan Kratochvil
Details | Diff
FC4 glibc-2.3.5-10 .spec patch for clear reproducibility (v2, incl. Bug1050) (2.12 KB, patch)
2005-07-05 07:39 UTC, Jan Kratochvil
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kratochvil 2005-07-03 10:41:59 UTC
glibc currently fails to build --disable-shared --enable-static-nss binary.
Just either one of these options also fails.

Besides the required dependencies patches also attached some patches which are
not importable, they just work for me.

Tested on: clean 2.3.5, Fedora Core 4 glibc-2.3.5-10, RawHide glibc-2.3.5-11
Resulting glibc still has broken NPTL libpthread but I do not need it.
Comment 1 Jan Kratochvil 2005-07-03 10:48:24 UTC
Created attachment 536 [details]
FC4 glibc-2.3.5-10 .spec patch for clear reproducibility

Patch also contains: LDFLAGS="-static"
to be able to build with: --disable-shared
It should not be required.

Another bug is the requirement to specify CFLAGS+LDFLAGS both for "configure"
and make(1).
Comment 2 Jan Kratochvil 2005-07-03 10:49:56 UTC
Created attachment 537 [details]
Remove dependency on libgcc_s.so which is impossible for: --disable-shared
Comment 3 Jan Kratochvil 2005-07-03 10:51:44 UTC
Created attachment 538 [details]
Fixes undefined linking crash for "--disable-shared". It may be a valid patch, not sure.
Comment 4 Jan Kratochvil 2005-07-05 07:39:32 UTC
Created attachment 544 [details]
FC4 glibc-2.3.5-10 .spec patch for clear reproducibility (v2, incl. Bug1050)
Comment 5 Roland McGrath 2005-07-19 03:44:29 UTC

*** This bug has been marked as a duplicate of 333 ***