Bug 9840

Summary: Windows flicker badly when resized in -multiwindow mode
Product: cygwin Reporter: Jon TURNEY <jon.turney>
Component: Cygwin/XAssignee: Yaakov Selkowitz <yselkowi>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Attachments: Patch to reduce resize flickering

Description Jon TURNEY 2009-02-12 18:15:23 UTC
 
Comment 1 Jon TURNEY 2009-02-12 18:18:35 UTC
Created attachment 3733 [details]
Patch to reduce resize flickering

Resizing windows in rootless mode causes them to flicker very badly.  This is
because the default WM_ERASEBKGND handling occurs, which erases the entire
invalidated area with the default (white) brush, pointlessly, before the entire
invalidated area is bitblt'ed from the shadow framebuffer.

Attached patch causes WM_ERASEBKGND handling to be skippped.
Comment 2 Yaakov Selkowitz 2009-02-12 19:58:20 UTC
Patch in the queue for 1.5.3-7.
Comment 3 Yaakov Selkowitz 2009-02-22 19:16:11 UTC
Pushed in 1.5.3-7; closing.