Bug 6663

Summary: testPeriodicTimer(frysk.event.TestPollEventLoop)java.lang.NoClassDefFoundError: frysk.sys.Poll
Product: frysk Reporter: Andrew Cagney <cagney>
Component: generalAssignee: Unassigned <frysk-bugzilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: cagney
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 6662    

Description Andrew Cagney 2008-06-20 13:15:04 UTC
testPeriodicTimer(frysk.event.TestPollEventLoop)java.lang.NoClassDefFoundError:
frysk.sys.Poll
   at java.lang.Class.initializeClass(libgcj.so.8rh)
   at frysk.event.PollEventLoop.signalEmpty(PollEventLoop.java:58)
   at frysk.event.EventLoop.<init>(EventLoop.java:67)
   at frysk.event.PollEventLoop.<init>(PollEventLoop.java:53)
   at frysk.event.TestPollEventLoop.newEventLoop(TestPollEventLoop.java:52)
   at frysk.event.EventLoopTestBed.setUp(EventLoopTestBed.java:67)
   at frysk.junit.Runner.runCases(Runner.java:214)
   at frysk.junit.Runner.runTestCases(Runner.java:441)
   at TestRunner.main(TestRunner.java:64)
Comment 1 Andrew Cagney 2008-06-20 21:19:18 UTC
Fixed by 6662's rewrite.

*** This bug has been marked as a duplicate of 6662 ***